aboutsummaryrefslogtreecommitdiff
path: root/deskutils/conkyemail/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'deskutils/conkyemail/Makefile')
-rw-r--r--deskutils/conkyemail/Makefile11
1 files changed, 9 insertions, 2 deletions
diff --git a/deskutils/conkyemail/Makefile b/deskutils/conkyemail/Makefile
index 2657107a4202..ffc3d801a980 100644
--- a/deskutils/conkyemail/Makefile
+++ b/deskutils/conkyemail/Makefile
@@ -3,6 +3,7 @@
PORTNAME= conkyemail
PORTVERSION= 2.07
+PORTREVISION= 1
CATEGORIES= deskutils
MASTER_SITES= http://launchpadlibrarian.net/28462213/ \
LOCAL/vg
@@ -11,18 +12,24 @@ DISTNAME= ${PORTNAME}_${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Email script for conky
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/COPYING
+
RUN_DEPENDS= conky:sysutils/conky
USES= python:2.7
USE_PYTHON= distutils
+
NO_BUILD= yes
NO_ARCH= yes
WRKSRC= ${WRKDIR}/src
post-patch:
- cd ${WRKSRC} && ${REINPLACE_CMD} -e 's,/usr/share/${PORTNAME},${DATADIR},g' \
+ @cd ${WRKSRC} && ${REINPLACE_CMD} -e 's,/usr/share/${PORTNAME},${DATADIR},g; \
+ s,%%DATADIR%%,${DATADIR},; \
+ s,%%PYTHON_CMD%%,${PYTHON_CMD},' \
conkyEmail conkyEmail.py setup.py example/conkyrc
- cd ${WRKSRC} && ${RM} -r example/conkyrc.bak
+ @cd ${WRKSRC} && ${RM} -r example/conkyrc.bak
.include <bsd.port.mk>