aboutsummaryrefslogtreecommitdiff
path: root/deskutils/etoile-distributedview/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'deskutils/etoile-distributedview/Makefile')
-rw-r--r--deskutils/etoile-distributedview/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/deskutils/etoile-distributedview/Makefile b/deskutils/etoile-distributedview/Makefile
new file mode 100644
index 000000000000..92db963b5aa3
--- /dev/null
+++ b/deskutils/etoile-distributedview/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: etoile-distributedview
+# Date created: 22 Dec 2006
+# Whom: dirk.meyer@dinoex.sub.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= distributedview
+PORTVERSION= 0.1.${SNAPSHOT}
+CATEGORIES= deskutils gnustep
+MASTER_SITES= ${MASTER_SITE_LOCAL}
+MASTER_SITE_SUBDIR= dinoex
+PKGNAMEPREFIX= etoile-
+DISTNAME= Etoile-${SNAPSHOT}
+
+MAINTAINER= dinoex@FreeBSD.org
+COMMENT= Etoile Project DistributedView framework
+
+USE_BZIP2= yes
+USE_GNUSTEP= yes
+USE_GNUSTEP_PREFIX= yes
+USE_GNUSTEP_BACK= yes
+USE_GNUSTEP_BUILD= yes
+USE_GNUSTEP_INSTALL= yes
+USE_GNUSTEP_LOCAL_LIBS+= EtoileUI:${ETOILE_UI_PORT}
+DEFAULT_LIBVERSION= 0.1
+USE_GNUSTEP_LDCONFIG= ${GNUSTEP_LOCAL_LIBRARIES}
+
+SNAPSHOT= 20061221
+WRKSRC= ${WRKDIR}/Etoile/
+USE_GNUSTEP_MAKE_DIRS+= Frameworks/DistributedView
+
+ETOILE_UI_PORT?= x11/etoile-ui
+
+.include <bsd.port.mk>