aboutsummaryrefslogtreecommitdiff
path: root/deskutils/genius/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'deskutils/genius/Makefile')
-rw-r--r--deskutils/genius/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/deskutils/genius/Makefile b/deskutils/genius/Makefile
index 39299faa252d..f266eac21319 100644
--- a/deskutils/genius/Makefile
+++ b/deskutils/genius/Makefile
@@ -19,6 +19,7 @@ COMMENT= Arbitrary precision calculator for Gnome Desktop Environment
LIB_DEPENDS= mpfr.1:${PORTSDIR}/math/mpfr
USE_X_PREFIX= yes
+USE_GETTEXT= yes
USE_GNOME= gnomehack gnomeprefix gnometarget gtksourceview intlhack \
libgnomeui vte
USE_GMAKE= yes
@@ -28,12 +29,16 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
CONFIGURE_ARGS= --disable-extra-gcc-optimization
INSTALLS_OMF= yes
+INSTALLS_ICONS= yes
.include <bsd.port.pre.mk>
+.if ${OSVERSION} < 500000 || exists(${LOCALBASE}/lib/libreadline.so.5)
+LIB_DEPENDS+= readline.5:${PORTSDIR}/devel/readline
+.endif
+
.if ${OSVERSION} < 500018
BROKEN= Does not compile on 4.x
-LIB_DEPENDS+= readline.5:${PORTSDIR}/devel/readline
.endif
.include <bsd.port.post.mk>