aboutsummaryrefslogtreecommitdiff
path: root/deskutils/gnome-shell-extension-weather/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'deskutils/gnome-shell-extension-weather/Makefile')
-rw-r--r--deskutils/gnome-shell-extension-weather/Makefile13
1 files changed, 6 insertions, 7 deletions
diff --git a/deskutils/gnome-shell-extension-weather/Makefile b/deskutils/gnome-shell-extension-weather/Makefile
index 2f7a9d3f20d5..8b61575d0dea 100644
--- a/deskutils/gnome-shell-extension-weather/Makefile
+++ b/deskutils/gnome-shell-extension-weather/Makefile
@@ -1,10 +1,8 @@
# Created by: Gustau Perez i Querol <gustau.perez@gmail.com>
# $FreeBSD$
-# $MCom: ports/trunk/deskutils/gnome-shell-extension-weather/Makefile 20013 2014-10-23 06:14:25Z gusi $
PORTNAME= gnome-shell-extension-weather
-PORTVERSION= 0.0.0.20140520
-PORTREVISION= 1
+PORTVERSION= 0.0.0.20141126
CATEGORIES= deskutils gnome
DIST_SUBDIR= gnome3
@@ -14,10 +12,10 @@ COMMENT= Weather extension for the GNOME3 shell
BUILD_DEPENDS= gnome-autogen.sh:${PORTSDIR}/devel/gnome-common
RUN_DEPENDS= gnome-shell>=0:${PORTSDIR}/x11/gnome-shell
-WRKSRC= ${WRKDIR}/Neroth-gnome-shell-extension-weather-489aaa0
+WRKSRC= ${WRKDIR}/Neroth-gnome-shell-extension-weather-${GH_COMMIT}
USES= autoreconf:build gettext gmake libtool pkgconfig tar:xz
-USE_GNOME= intltool
+USE_GNOME= glib20 intlhack
USE_GITHUB= yes
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
@@ -25,8 +23,8 @@ CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
GH_ACCOUNT= Neroth
-GH_TAGNAME= 489aaa0a7a
-GH_COMMIT= 489aaa0a7a
+GH_TAGNAME= 329139f
+GH_COMMIT= 329139f
PKGMESSAGE= ../gnome-shell-extra-extensions/pkg-message.slaves
@@ -34,5 +32,6 @@ GLIB_SCHEMAS= org.gnome.shell.extensions.weather.gschema.xml
pre-configure:
cd ${WRKSRC} && NOCONFIGURE=yes ${SH} ./autogen.sh
+ ${intlhack_PRE_PATCH}
.include <bsd.port.mk>