aboutsummaryrefslogtreecommitdiff
path: root/deskutils/gourmet/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'deskutils/gourmet/Makefile')
-rw-r--r--deskutils/gourmet/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/deskutils/gourmet/Makefile b/deskutils/gourmet/Makefile
index 91c88a81b8b8..d337469dee8f 100644
--- a/deskutils/gourmet/Makefile
+++ b/deskutils/gourmet/Makefile
@@ -17,12 +17,15 @@ COMMENT= GNOME recipe manager
RUN_DEPENDS= ${LOCALBASE}/lib/libmk4py.so:${PORTSDIR}/databases/metakit \
${PYTHON_SITELIBDIR}/PIL/__init__.py:${PORTSDIR}/graphics/py-imaging
-BROKEN= Changes file permission of installed file
-
USE_X_PREFIX= yes
USE_PYTHON= yes
USE_PYDISTUTILS=yes
USE_GNOME= pygnome2
+post-install:
+.if exists(${PYTHON_SITELIBDIR}/metakit.pyc)
+ @${CHMOD} 0555 ${PYTHON_SITELIBDIR}/metakit.pyc
+.endif
+
.include <bsd.port.mk>