aboutsummaryrefslogtreecommitdiff
path: root/deskutils/griffith/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'deskutils/griffith/Makefile')
-rw-r--r--deskutils/griffith/Makefile10
1 files changed, 6 insertions, 4 deletions
diff --git a/deskutils/griffith/Makefile b/deskutils/griffith/Makefile
index ac23d40f19ff..4a9eb5c00258 100644
--- a/deskutils/griffith/Makefile
+++ b/deskutils/griffith/Makefile
@@ -3,7 +3,7 @@
PORTNAME= griffith
PORTVERSION= 0.13
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= deskutils
MASTER_SITES= http://launchpadlibrarian.net/87859599/
@@ -22,7 +22,8 @@ USE_GNOME= pygtk2
USES= gmake gettext python tar:xz
NO_BUILD= yes
-OPTIONS_DEFINE= CHARDET LXML PYGNOMEEXTRAS REPORTLAB2
+OPTIONS_DEFINE= CHARDET LXML PYGNOMEEXTRAS REPORTLAB2
+OPTIONS_DEFAULT= LXML
CHARDET_DESC= chardet support
CHARDET_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}chardet>=0:${PORTSDIR}/textproc/py-chardet
@@ -50,10 +51,11 @@ post-patch:
/^PREFIX/s|?=|=|g ; s|/usr|${PREFIX}|; /ln -s/d; \
/^ETCDIR/s|=.*|= $$(PREFIX)/etc|g' ${WRKSRC}/${file}
.endfor
-.for file in docs/en/Makefile docs/pl/Makefile docs/pt/Makefile
+.for f in docs/en/Makefile docs/pl/Makefile docs/pt/Makefile
@${REINPLACE_CMD} -e \
'/^PREFIX/s|?=|=|g ; s|/usr|${PREFIX}|; \
- /^MANDIR/s|=.*|=${STAGEDIR}${MANPREFIX}/man|g' ${WRKSRC}/${file}
+ /^MANDIR/s|=.*|=${STAGEDIR}${MANPREFIX}/man|g' \
+ ${WRKSRC}/${f}
.endfor
pre-install: