aboutsummaryrefslogtreecommitdiff
path: root/deskutils/hot-babe/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'deskutils/hot-babe/Makefile')
-rw-r--r--deskutils/hot-babe/Makefile11
1 files changed, 11 insertions, 0 deletions
diff --git a/deskutils/hot-babe/Makefile b/deskutils/hot-babe/Makefile
index e4dc679a3fd3..7d2426fe6abe 100644
--- a/deskutils/hot-babe/Makefile
+++ b/deskutils/hot-babe/Makefile
@@ -7,6 +7,7 @@
PORTNAME= hot-babe
PORTVERSION= 0.1.4
+PORTREVISION= 1
CATEGORIES= deskutils
MASTER_SITES= http://dindinx.net/hotbabe/downloads/
@@ -17,6 +18,9 @@ USE_BZIP2= yes
USE_X_PREFIX= yes
MAKE_ARGS+= PREFIX="${PREFIX}" CC="${CC}"
USE_GNOME= gdkpixbuf
+USE_REINPLACE= yes
+
+MAN1= hot-babe.1
pre-everything::
@${ECHO_MSG}
@@ -24,4 +28,11 @@ pre-everything::
@${ECHO_MSG} "You might hit Ctrl-C to abort."
@${ECHO_MSG}
+post-patch:
+ @${REINPLACE_CMD} -e 's|gtk-config|${GTK_CONFIG}|g;s|gdk-pixbuf-config|${GDK_PIXBUF_CONFIG}|g' \
+ ${WRKSRC}/Makefile
+
+post-install:
+ ${INSTALL_MAN} ${WRKSRC}/hot-babe.1 ${PREFIX}/man/man1
+
.include <bsd.port.mk>