aboutsummaryrefslogtreecommitdiff
path: root/deskutils/journal
diff options
context:
space:
mode:
Diffstat (limited to 'deskutils/journal')
-rw-r--r--deskutils/journal/Makefile27
-rw-r--r--deskutils/journal/distinfo1
-rw-r--r--deskutils/journal/pkg-descr7
-rw-r--r--deskutils/journal/pkg-plist2
4 files changed, 37 insertions, 0 deletions
diff --git a/deskutils/journal/Makefile b/deskutils/journal/Makefile
new file mode 100644
index 000000000000..be64fa093640
--- /dev/null
+++ b/deskutils/journal/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: Jose Devezas
+# Date created: 3 November 2003
+# Whom: Jose Devezas <jose.devezas@fe.up.pt>
+#
+# $FreeBSD$
+#
+
+PORTNAME= journal
+PORTVERSION= 0.4
+CATEGORIES= deskutils
+MASTER_SITES= http://soapbox.fissure.org/journal/
+
+MAINTAINER= jose.devezas@fe.up.pt
+COMMENT= Journal is a tool for replacing the traditional text-based diary
+
+NO_BUILD= yes
+USE_PYTHON= yes
+USE_REINPLACE= yes
+
+do-patch:
+ ${REINPLACE_CMD} -e "s,#!/usr/bin/python,#!${PYTHON_CMD}," ${WRKSRC}/journal.py
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/journal.py ${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKSRC}/journ_classes.py ${PYTHON_SITELIBDIR}
+
+.include <bsd.port.mk>
diff --git a/deskutils/journal/distinfo b/deskutils/journal/distinfo
new file mode 100644
index 000000000000..adf7e34f2df3
--- /dev/null
+++ b/deskutils/journal/distinfo
@@ -0,0 +1 @@
+MD5 (journal-0.4.tar.gz) = 3c9edf53218dc8c7b8d2b00fd3f58690
diff --git a/deskutils/journal/pkg-descr b/deskutils/journal/pkg-descr
new file mode 100644
index 000000000000..36473702880e
--- /dev/null
+++ b/deskutils/journal/pkg-descr
@@ -0,0 +1,7 @@
+From Freshmeat:
+
+Journal is a small tool useful for replacing the traditional text-based diary.
+Its features include multpile user support, multiple journals for each user,
+encryption, reading and writing new entries, and timestamping of entries.
+
+WWW: http://soapbox.fissure.org/journal/journal.html
diff --git a/deskutils/journal/pkg-plist b/deskutils/journal/pkg-plist
new file mode 100644
index 000000000000..312271596a73
--- /dev/null
+++ b/deskutils/journal/pkg-plist
@@ -0,0 +1,2 @@
+bin/journal.py
+%%PYTHON_SITELIBDIR%%/journ_classes.py