aboutsummaryrefslogtreecommitdiff
path: root/deskutils/kdepim4/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'deskutils/kdepim4/Makefile')
-rw-r--r--deskutils/kdepim4/Makefile24
1 files changed, 3 insertions, 21 deletions
diff --git a/deskutils/kdepim4/Makefile b/deskutils/kdepim4/Makefile
index fdaf93bad786..3f3f9cf6d6b6 100644
--- a/deskutils/kdepim4/Makefile
+++ b/deskutils/kdepim4/Makefile
@@ -15,6 +15,8 @@ DIST_SUBDIR= KDE
MAINTAINER= kde@FreeBSD.org
COMMENT= Personal Information Management tools for KDE
+LIB_DEPENDS= pisock:${PORTSDIR}/palm/pilot-link
+
USE_KDELIBS_VER=3
PREFIX= ${KDE_PREFIX}
@@ -23,7 +25,6 @@ USE_BISON= yes
GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_REINPLACE= yes
-KDE_BUILD_PLIST=yes
INSTALLS_SHLIB= yes
LDCONFIG_DIRS+= %%PREFIX%%/lib %%PREFIX%%/lib/kde3
@@ -32,25 +33,6 @@ LDCONFIG_DIRS+= %%PREFIX%%/lib %%PREFIX%%/lib/kde3
.include <bsd.port.pre.mk>
pre-configure::
- ${REINPLACE_CMD} -e "s@-pedantic @@g; \
- s@/usr/local/include/libmal@${LOCALBASE}/include/libmal@g" \
- ${WRKSRC}/configure
-
-.if exists(${LOCALBASE}/bin/pilot-xfer)
-WITH_KPILOT=YES
-.endif # exists(${LOCALBASE}/bin/pilot-xfer)
-
-.if defined(WITH_KPILOT)
-LIB_DEPENDS+= pisock:${PORTSDIR}/palm/pilot-link \
- mal:${PORTSDIR}/palm/libmal
-PLIST_APPEND+= plist.kpilot
-.else
- @${ECHO_MSG}
- @${ECHO_MSG} "====================================================="
- @${ECHO_MSG} "If you want to compile with Palm Pilot support, hit"
- @${ECHO_MSG} "Ctrl-C right now and use \"make WITH_KPILOT=yes\""
- @${ECHO_MSG} "====================================================="
- @${ECHO_MSG}
-.endif # defined(WITH_KPILOT)
+ ${REINPLACE_CMD} -e 's@-pedantic @@g' ${WRKSRC}/configure
.include <bsd.port.post.mk>