aboutsummaryrefslogtreecommitdiff
path: root/deskutils/kdepim4/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'deskutils/kdepim4/Makefile')
-rw-r--r--deskutils/kdepim4/Makefile21
1 files changed, 9 insertions, 12 deletions
diff --git a/deskutils/kdepim4/Makefile b/deskutils/kdepim4/Makefile
index 7e147c85a6ca..1dedf349f750 100644
--- a/deskutils/kdepim4/Makefile
+++ b/deskutils/kdepim4/Makefile
@@ -7,16 +7,20 @@
PORTNAME= kdepim
PORTVERSION= ${KDE_VERSION}
-PORTREVISION= 1
-CATEGORIES= deskutils mail news kde
+CATEGORIES= deskutils mail news palm kde
MASTER_SITES= ${MASTER_SITE_KDE}
-MASTER_SITE_SUBDIR= stable/${PORTVERSION}/src
+MASTER_SITE_SUBDIR= stable/${PORTVERSION:S/.0//}/src
DIST_SUBDIR= KDE
MAINTAINER= kde@FreeBSD.org
COMMENT= Personal Information Management tools for KDE
-CONFLICTS= kdenetwork-3.1.*
+BUILD_DEPENDS= gpg:${PORTSDIR}/security/gnupg \
+ gpgsm:${PORTSDIR}/security/gnupg-devel
+LIB_DEPENDS= mal:${PORTSDIR}/palm/libmal \
+ pisock:${PORTSDIR}/palm/pilot-link
+
+CONFLICTS= kdenetwork-3.1.* kdeaddons-kontact-plugins-[0-9]* kdepim-kpilot-3.2.3
USE_KDELIBS_VER=3
PREFIX= ${KDE_PREFIX}
@@ -29,10 +33,8 @@ USE_REINPLACE= yes
INSTALLS_SHLIB= yes
LDCONFIG_DIRS+= %%PREFIX%%/lib %%PREFIX%%/lib/kde3
-DO_NOT_COMPILE+=kpilot
-OPTIONS= KPILOT "Build KPilot, hotsync software for KDE" off \
- GNOKII "KAdressbook import/export for Nokia phones" off
+OPTIONS= GNOKII "KAdressbook import/export for Nokia phones" off
.include "${.CURDIR}/../../x11/kde3/Makefile.kde"
.include <bsd.port.pre.mk>
@@ -48,10 +50,6 @@ WITH_GNOKII= yes
LIB_DEPENDS+= gnokii:${PORTSDIR}/comms/gnokii
.endif # defined ($(WITH_GNOKII))
-.if defined(WITH_KPILOT)
-RUN_DEPENDS+= kpilot:${PORTSDIR}/palm/kpilot
-.endif
-
.if defined(DO_NOT_COMPILE)
CONFIGURE_ENV+=DO_NOT_COMPILE="${DO_NOT_COMPILE}"
.endif # defined(DO_NOT_COMPILE)
@@ -69,6 +67,5 @@ pre-everything::
pre-configure:
${REINPLACE_CMD} -e 's|-ldl||' ${WRKSRC}/configure
${REINPLACE_CMD} -e 's|-lgnokii|-lgnokii -liconv -lintl|' ${WRKSRC}/configure
- ${REINPLACE_CMD} -e '/^SUBDIRS/s/kpilot//g' ${WRKSRC}/doc/Makefile.in
.include <bsd.port.post.mk>