aboutsummaryrefslogtreecommitdiff
path: root/deskutils/kompose
diff options
context:
space:
mode:
Diffstat (limited to 'deskutils/kompose')
-rw-r--r--deskutils/kompose/Makefile35
-rw-r--r--deskutils/kompose/distinfo2
-rw-r--r--deskutils/kompose/pkg-descr5
-rw-r--r--deskutils/kompose/pkg-plist12
4 files changed, 54 insertions, 0 deletions
diff --git a/deskutils/kompose/Makefile b/deskutils/kompose/Makefile
new file mode 100644
index 000000000000..6dda58fe27af
--- /dev/null
+++ b/deskutils/kompose/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: kompose
+# Date created: 31 Aug 2004
+# Whom: Lauri Watts <lauri@kde.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= kompose
+PORTVERSION= 0.4.2
+CATEGORIES= deskutils kde
+MASTER_SITES= http://download.berlios.de/kompose/
+
+MAINTAINER= lauri@kde.org
+COMMENT= Full-screen task manager similar to Exposé(tm)
+
+LIB_DEPENDS= Imlib2:${PORTSDIR}/graphics/imlib2
+
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_REINPLACE= yes
+USE_KDELIBS_VER= 3
+GNU_CONFIGURE= yes
+
+.if defined(WITHOUT_NLS)
+CONFIGURE_ARGS+=--disable-nls
+PLIST_SUB+= NLS="@comment "
+.else
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|-O2 ||g' ${WRKSRC}/configure
+
+.include <bsd.port.mk>
diff --git a/deskutils/kompose/distinfo b/deskutils/kompose/distinfo
new file mode 100644
index 000000000000..62f21e1fc641
--- /dev/null
+++ b/deskutils/kompose/distinfo
@@ -0,0 +1,2 @@
+MD5 (kompose-0.4.2.tar.bz2) = b51839098432590c0903da3e75a853ac
+SIZE (kompose-0.4.2.tar.bz2) = 492247
diff --git a/deskutils/kompose/pkg-descr b/deskutils/kompose/pkg-descr
new file mode 100644
index 000000000000..209c41ca16ba
--- /dev/null
+++ b/deskutils/kompose/pkg-descr
@@ -0,0 +1,5 @@
+Kompose offers a great new way to manage a big number of windows on
+different Virtual Desktops. It creates a fullscreen view where every window
+is represented by a scaled screenshot of its own.
+
+WWW: http://kompose.berlios.de/
diff --git a/deskutils/kompose/pkg-plist b/deskutils/kompose/pkg-plist
new file mode 100644
index 000000000000..fc464f77c2b0
--- /dev/null
+++ b/deskutils/kompose/pkg-plist
@@ -0,0 +1,12 @@
+bin/kompose
+share/applnk/Utilities/kompose.desktop
+share/apps/kompose/komposeui.rc
+share/doc/HTML/en/kompose/common
+share/doc/HTML/en/kompose/index.cache.bz2
+share/doc/HTML/en/kompose/index.docbook
+share/icons/hicolor/16x16/apps/kompose.png
+share/icons/hicolor/32x32/apps/kompose.png
+%%NLS%%share/locale/da/LC_MESSAGES/kompose.mo
+%%NLS%%@dirrm share/locale/da/LC_MESSAGES
+@dirrm share/doc/HTML/en/kompose
+@dirrm share/apps/kompose