aboutsummaryrefslogtreecommitdiff
path: root/deskutils/logjam/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'deskutils/logjam/Makefile')
-rw-r--r--deskutils/logjam/Makefile52
1 files changed, 46 insertions, 6 deletions
diff --git a/deskutils/logjam/Makefile b/deskutils/logjam/Makefile
index 549becdbe2dc..0ee3a5666f3c 100644
--- a/deskutils/logjam/Makefile
+++ b/deskutils/logjam/Makefile
@@ -6,20 +6,60 @@
#
PORTNAME= logjam
-PORTVERSION= 3.0.4
-PORTREVISION= 1
+PORTVERSION= 4.4.0
CATEGORIES= deskutils
MASTER_SITES= http://logjam.danga.com/download/
-MAINTAINER= ports@FreeBSD.org
-COMMENT= A GTK interface to user journals on www.livejournal.com
+MAINTAINER= mike.patterson@unb.ca
+COMMENT= A GTK2 interface to livejournals, ie www.livejournal.com
LIB_DEPENDS= curl.2:${PORTSDIR}/ftp/curl
MAN1= logjam.1
+USE_BZIP2= yes
USE_GMAKE= yes
+WANT_GNOME= yes
+USE_X_PREFIX= yes
GNU_CONFIGURE= yes
-USE_GNOME= gtk12
+USE_GNOME= gnomehack gnomeprefix gtk20 libxml2 intlhack
+CONFIGURE_ARGS= --program-transform-name="s/$$//"
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LIBS="-L${LOCALBASE}/lib"
-.include <bsd.port.mk>
+.ifndef(WITHOUT_GTKSPELL)
+LIB_DEPENDS+= gtkspell.0:${PORTSDIR}/textproc/gtkspell2
+.else
+CONFIGURE_ARGS+= --without-gtkspell
+.endif
+
+.if defined(WITH_XMMS)
+LIB_DEPENDS+= xmms.4:${PORTSDIR}/multimedia/xmms
+PLIST_SUB+= WITH_XMMS=""
+.else
+PLIST_SUB+= WITH_XMMS="@comment "
+CONFIGURE_ARGS+= --without-xmms
+.endif
+
+.include <bsd.port.pre.mk>
+
+.if ${HAVE_GNOME:Mgtkhtml3}!=""
+USE_GNOME+= gtkhtml3
+.else
+CONFIGURE_ARGS+= --without-gtkhtml
+.endif
+
+.if ${HAVE_GNOME:Mlibrsvg2}!=""
+USE_GNOME+= librsvg2
+.else
+CONFIGURE_ARGS+= --without-librsvg
+.endif
+
+pre-everything::
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} "logjam has the following tunable option(s):"
+ @${ECHO_MSG} " WITHOUT_GTKSPELL Disable spell checking"
+ @${ECHO_MSG} " WITH_XMMS Enable XMMS music detection"
+ @${ECHO_MSG} ""
+
+.include <bsd.port.post.mk>