aboutsummaryrefslogtreecommitdiff
path: root/deskutils/moregroupware/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'deskutils/moregroupware/Makefile')
-rw-r--r--deskutils/moregroupware/Makefile42
1 files changed, 42 insertions, 0 deletions
diff --git a/deskutils/moregroupware/Makefile b/deskutils/moregroupware/Makefile
new file mode 100644
index 000000000000..d4b6f7c12011
--- /dev/null
+++ b/deskutils/moregroupware/Makefile
@@ -0,0 +1,42 @@
+# New ports collection makefile for: deskutils/moregroupware
+# Date created: December 30th 2003
+# Whom: Rob Evers <rob@debank.tv>
+#
+# $FreeBSD$
+#
+
+PORTNAME= moregroupware
+PORTVERSION= 0.7.1
+CATEGORIES= deskutils www
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= moregroupware
+DISTNAME= ${PORTNAME}-core-${PORTVERSION}${EXTRACT_SUFX}
+.if !defined(NOPORTDOCS)
+DISTFILES= ${PORTNAME}-core-${PORTVERSION}${EXTRACT_SUFX} \
+ ${PORTNAME}-docs-${PORTVERSION}${EXTRACT_SUFX}
+.endif
+
+MAINTAINER= rob@debank.tv
+COMMENT= A web based GroupWare system
+
+.if defined(WITH_APACHE2)
+RUN_DEPENDS= ${LOCALBASE}/libexec/apache2/libphp4.so:${PORTSDIR}/www/mod_php4
+.else
+RUN_DEPENDS= ${LOCALBASE}/libexec/apache/libphp4.so:${PORTSDIR}/www/mod_php4
+.endif
+
+.if defined(WITH_MODULES)
+DISTFILES+= ${PORTNAME}-modules-insecure-${PORTVERSION}${EXTRACT_SUFX}
+PLIST_SUB+= MODULES=""
+.else
+PLIST_SUB+= MODULES="@comment "
+.endif
+
+NO_BUILD= yes
+WRKSRC= ${WRKDIR}/moregroupware
+
+do-install:
+ @${CP} -r ${WRKSRC} ${PREFIX}/www/
+ @${CHOWN} -R ${WWWOWN}:${WWWGRP} ${PREFIX}/www/moregroupware
+
+.include <bsd.port.mk>