aboutsummaryrefslogtreecommitdiff
path: root/deskutils/multisync/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'deskutils/multisync/Makefile')
-rw-r--r--deskutils/multisync/Makefile42
1 files changed, 42 insertions, 0 deletions
diff --git a/deskutils/multisync/Makefile b/deskutils/multisync/Makefile
new file mode 100644
index 000000000000..0656341e31cd
--- /dev/null
+++ b/deskutils/multisync/Makefile
@@ -0,0 +1,42 @@
+# New ports collection makefile for: multisync
+# Date created: 25 Nov 2003
+# Whom: Pav Lucistnik <pav@FreeBSD.org>
+#
+# $FreeBSD$
+
+PORTNAME?= multisync
+PORTVERSION= 0.81
+CATEGORIES= deskutils
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= multisync-${PORTVERSION}
+
+MAINTAINER?= pav@FreeBSD.org
+COMMENT?= Synchronize calendars, addressbooks and other PIM data
+
+PATCH_DEPENDS+= ${LOCALBASE}/share/automake17/depcomp:${PORTSDIR}/devel/automake17
+
+WRKSRC?= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+WRKSRCMASTER= ${WRKDIR}/multisync-${PORTVERSION}
+USE_BZIP2= yes
+USE_GNOME= gnomehack gnomeprefix libgnomeui
+USE_GMAKE= yes
+USE_LIBTOOL_VER= 14
+USE_X_PREFIX= yes
+CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" LIBS="-L${LOCALBASE}/lib"
+
+AUTOMAKE_FILES= missing install-sh mkinstalldirs config.guess config.sub depcomp
+
+post-patch:
+ @${FIND} ${WRKDIR} -type l -delete
+.for FILE in ${AUTOMAKE_FILES}
+ @${CP} -f ${LOCALBASE}/share/automake17/${FILE} ${WRKSRC}
+ @${CP} -f ${LOCALBASE}/share/automake17/${FILE} ${WRKSRCMASTER}
+.endfor
+ @${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${REINPLACE_CMD} -e \
+ 's|-lpthread||'
+
+post-configure:
+ ${CP} ${LOCALBASE}/bin/libtool14 ${WRKSRC}/libtool
+
+.include <bsd.port.mk>