aboutsummaryrefslogtreecommitdiff
path: root/deskutils/nautilus-actions/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'deskutils/nautilus-actions/Makefile')
-rw-r--r--deskutils/nautilus-actions/Makefile33
1 files changed, 25 insertions, 8 deletions
diff --git a/deskutils/nautilus-actions/Makefile b/deskutils/nautilus-actions/Makefile
index eaaf7cabd6f0..9ca311974ecb 100644
--- a/deskutils/nautilus-actions/Makefile
+++ b/deskutils/nautilus-actions/Makefile
@@ -3,19 +3,21 @@
# Whom: Michael Johnson <ahze@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports/deskutils/nautilus-actions/Makefile,v 1.7 2008/03/18 14:45:27 ahze Exp $
+# $MCom: ports/deskutils/nautilus-actions/Makefile,v 1.14 2009/11/09 09:08:28 kwm Exp $
#
PORTNAME= nautilus-actions
-PORTVERSION= 1.4.1
-PORTREVISION= 3
+PORTVERSION= 1.12.3
CATEGORIES= deskutils
-MASTER_SITES= ftp://ftp2.grumz.net/grumz/
+MASTER_SITES= GNOME \
+ http://www.nautilus-actions.org/downloads/ \
+ ftp://pwi.dyndns.biz/pub/tarballs/nautilus-actions/
-MAINTAINER= ahze@FreeBSD.org
+MAINTAINER= gnome@FreeBSD.org
COMMENT= Extension for Nautilus to configure programs to launch on files
-LIB_DEPENDS= uuid.1:${PORTSDIR}/misc/e2fsprogs-libuuid
+LIB_DEPENDS= uuid.1:${PORTSDIR}/misc/e2fsprogs-libuuid \
+ unique-1.0.2:${PORTSDIR}/x11-toolkits/unique
INSTALLS_ICONS= yes
USE_GETTEXT= yes
@@ -26,7 +28,22 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
CONFIGURE_ARGS= --with-nautilus-extdir=${LOCALBASE}/lib/nautilus/extensions-2.0
+PORTDOCS= AUTHORS COPYING ChangeLog ChangeLog-2008 INSTALL MAINTAINERS \
+ NEWS README TODO objects-hierarchy.odg
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 700000
+EXTRA_PATCHES+= ${FILESDIR}/extra-patch-configure
+.endif
+
post-patch:
- @${REINPLACE_CMD} -e 's|echo aout|echo elf|' ${WRKSRC}/configure
+.if defined(NOPORTDOCS)
+ @${REINPLACE_CMD} -e 's| install-dist_pkgdocDATA||g' \
+ ${WRKSRC}/Makefile.in ${WRKSRC}/doc/Makefile.in
+.else
+ @${REINPLACE_CMD} -e 's|doc/@PACKAGE@-@VERSION@|doc/@PACKAGE@|g' \
+ ${WRKSRC}/Makefile.in ${WRKSRC}/doc/Makefile.in
+.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>>