aboutsummaryrefslogtreecommitdiff
path: root/deskutils/orage/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'deskutils/orage/Makefile')
-rw-r--r--deskutils/orage/Makefile21
1 files changed, 9 insertions, 12 deletions
diff --git a/deskutils/orage/Makefile b/deskutils/orage/Makefile
index 804ae8b4f01a..2923eb629434 100644
--- a/deskutils/orage/Makefile
+++ b/deskutils/orage/Makefile
@@ -2,24 +2,24 @@
# $FreeBSD$
PORTNAME= orage
-PORTVERSION= 4.8.3
-PORTREVISION= 2
+PORTVERSION= 4.8.4
CATEGORIES= deskutils xfce
MASTER_SITES= ${MASTER_SITE_XFCE}
-MASTER_SITE_SUBDIR=/src/apps/${PORTNAME}/${PORTVERSION:R}
+MASTER_SITE_SUBDIR=src/apps/${PORTNAME}/${PORTVERSION:R}
DIST_SUBDIR= xfce4
MAINTAINER= xfce@FreeBSD.org
COMMENT= A calendar application to manage your time with Xfce 4
-LIB_DEPENDS= popt.0:${PORTSDIR}/devel/popt
+LIB_DEPENDS= popt:${PORTSDIR}/devel/popt
GNU_CONFIGURE= yes
INSTALLS_ICONS= yes
USE_BZIP2= yes
USE_GETTEXT= yes
USE_GMAKE= yes
-USE_GNOME= gnomehack gtk20 intltool intlhack pkgconfig desktopfileutils
+USE_GNOME= gnomehack gtk20 intltool intlhack desktopfileutils
+USE_PKGCONFIG= build
USE_XFCE= configenv libmenu panel
USE_XORG= xext xrender xinerama xi xrandr xcursor xcomposite xdamage x11 \
xfixes
@@ -31,7 +31,7 @@ ICAL_DESC= libical support
MAN1= globaltime.1 orage.1 tz_convert.1
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MBDB}
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-configure
@@ -54,7 +54,7 @@ PLIST_SUB+= WITH_ICAL=""
.endif
.if ${PORT_OPTIONS:MDBUS}
-LIB_DEPENDS+= dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib
+LIB_DEPENDS+= dbus-glib-1:${PORTSDIR}/devel/dbus-glib
CONFIGURE_ARGS+=--enable-dbus
PLIST_SUB+= DBUS=""
.else
@@ -63,7 +63,7 @@ PLIST_SUB+= DBUS="@comment "
.endif
.if ${PORT_OPTIONS:MNOTIFY}
-LIB_DEPENDS+= notify.4:${PORTSDIR}/devel/libnotify
+LIB_DEPENDS+= notify:${PORTSDIR}/devel/libnotify
CONFIGURE_ARGS+=--enable-libnotify
.else
CONFIGURE_ARGS+=--disable-libnotify
@@ -75,9 +75,6 @@ post-patch:
s|%%BDB_LIB_DIR%%|${BDB_LIB_DIR}|g ; \
s|%%BDB_LIB_NAME%%|${BDB_LIB_NAME}|g' ${WRKSRC}/configure
.endif
-.if empty(PORT_OPTIONS:MICAL)
- @${REINPLACE_CMD} -e 's|libical-|no-&|g' ${WRKSRC}/configure
-.endif
@${REINPLACE_CMD} -e 's|echo aout|echo elf|g' ${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|(datadir)/orage/doc/C|(datadir)/doc/orage/C|' \
${WRKSRC}/doc/C/Makefile.in \
@@ -86,4 +83,4 @@ post-patch:
post-install:
@-update-desktop-database
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>