aboutsummaryrefslogtreecommitdiff
path: root/deskutils/pinot/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'deskutils/pinot/Makefile')
-rw-r--r--deskutils/pinot/Makefile35
1 files changed, 27 insertions, 8 deletions
diff --git a/deskutils/pinot/Makefile b/deskutils/pinot/Makefile
index d554dba643d0..b62aad1998e8 100644
--- a/deskutils/pinot/Makefile
+++ b/deskutils/pinot/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= pinot
-PORTVERSION= 0.76
-PORTREVISION= 3
+PORTVERSION= 0.81
CATEGORIES= deskutils
MASTER_SITES= ${MASTER_SITE_BERLIOS}
#MASTER_SITES= http://www.chez.com/colinf/pinot/ \
@@ -33,19 +32,22 @@ RUN_DEPENDS= update-mime-database:${PORTSDIR}/misc/shared-mime-info \
antiword:${PORTSDIR}/textproc/antiword \
xdg-open:${PORTSDIR}/devel/xdg-utils \
pdftotext:${PORTSDIR}/graphics/xpdf \
+ catppt:${PORTSDIR}/textproc/catdoc \
unzip:${PORTSDIR}/archivers/unzip \
- unrtf:${PORTSDIR}/textproc/unrtf
+ unrtf:${PORTSDIR}/textproc/unrtf \
+ catdvi:${PORTSDIR}/print/catdvi
+LDFLAGS+= -L${LOCALBASE}/lib
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
-CONFIGURE_ARGS= --with-http=curl
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib" \
- MKDIR_P="mkdir -p"
+CONFIGURE_ARGS= --with-http=curl --with-ssl=${OPENSSLBASE}
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" MKDIR_P="${MKDIR}"
USE_GETTEXT= yes
USE_XLIB= yes
#USE_SQLITE= 3 # Replaced by sqlite3-threads
USE_PYTHON= yes
+USE_OPENSSL= yes
USE_LDCONFIG= ${PREFIX}/lib/pinot/filters
.if defined(WITH_SOAP)
@@ -62,7 +64,7 @@ SQ3THOL= ${LOCALBASE}/share/sqlite3/sqlite3_with_threads-override-locks
INSTALLS_ICONS= yes
SUB_FILES= pkg-message
-PKGMESSAGE= ${WRKDIR}/pkg-message
+PLIST_SUB= DESKBAR_MOD="${LDESKBAR_MOD}"
MAN1= pinot-dbus-daemon.1 pinot-index.1 pinot-search.1 pinot.1
@@ -72,6 +74,15 @@ LM2FIX= textcat_conf.txt textcat3_conf.txt
SHR2FIX= Search/pinot-search.1 README
UL2FIX= Utils/xdgmime/xdgmime.c
+LDESKBAR_MOD= lib/deskbar-applet/modules-2.20-compatible
+DESKBAR_MOD= ${PREFIX}/${LDESKBAR_MOD}
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 700041
+PKGMESSAGE= ${WRKDIR}/pkg-message
+.endif
+
post-extract:
# remove pre-generated messages catalogs
${FIND} ${WRKSRC}/po -name "*.gmo" -delete
@@ -88,6 +99,12 @@ pre-configure:
${WRKSRC}/*.desktop
post-install:
+ ${MKDIR} ${DESKBAR_MOD}
+.for pyscript in pinot-module
+ ${INSTALL_DATA} ${WRKSRC}/scripts/python/${pyscript}.py ${DESKBAR_MOD}
+.endfor
+ @${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py ${DESKBAR_MOD}
+ @${PYTHON_CMD} -O ${PYTHON_LIBDIR}/compileall.py ${DESKBAR_MOD}
@${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py \
${PREFIX}/lib/deskbar-applet/handlers
@${PYTHON_CMD} -O ${PYTHON_LIBDIR}/compileall.py \
@@ -96,8 +113,10 @@ post-install:
${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
.endif
+.if ${OSVERSION} < 700041
@${ECHO_MSG}
@${CAT} ${PKGMESSAGE}
@${ECHO_MSG}
+.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>