aboutsummaryrefslogtreecommitdiff
path: root/deskutils/plasma-applet-yawp/files/patch-applet__CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'deskutils/plasma-applet-yawp/files/patch-applet__CMakeLists.txt')
-rw-r--r--deskutils/plasma-applet-yawp/files/patch-applet__CMakeLists.txt26
1 files changed, 26 insertions, 0 deletions
diff --git a/deskutils/plasma-applet-yawp/files/patch-applet__CMakeLists.txt b/deskutils/plasma-applet-yawp/files/patch-applet__CMakeLists.txt
new file mode 100644
index 000000000000..6abb26abaf07
--- /dev/null
+++ b/deskutils/plasma-applet-yawp/files/patch-applet__CMakeLists.txt
@@ -0,0 +1,26 @@
+--- ./applet/CMakeLists.txt.orig 2009-12-06 15:08:29.000000000 -0500
++++ ./applet/CMakeLists.txt 2010-02-05 03:23:32.000000000 -0500
+@@ -54,23 +54,3 @@
+ DESTINATION ${DATA_INSTALL_DIR}/desktoptheme/default/widgets/
+ )
+
+-
+-## This is needed for the CPack package generator.
+-#
+-INSTALL(TARGETS plasma_yawp
+- LIBRARY DESTINATION "${YAWP_PACK_INSTALL_LIB_DIR}"
+- ARCHIVE DESTINATION "${YAWP_PACK_INSTALL_LIB_DIR}"
+- RUNTIME DESTINATION "${YAWP_PACK_INSTALL_LIB_DIR}"
+- COMPONENT Libraries
+- )
+-
+-INSTALL(FILES plasma_yawp.desktop
+- DESTINATION "${YAWP_PACK_SERVICES_DIR}"
+- COMPONENT ApplicationData
+- )
+-
+-STRING(REGEX REPLACE "/usr/" "" YAWP_PACK_DATA_DIR "${DATA_INSTALL_DIR}/desktoptheme/default/widgets/")
+-INSTALL(FILES yawp_theme15.svg
+- DESTINATION "${YAWP_PACK_DATA_DIR}"
+- COMPONENT ApplicationData
+- )