aboutsummaryrefslogtreecommitdiff
path: root/deskutils/recoll/files/patch-lib__Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'deskutils/recoll/files/patch-lib__Makefile')
-rw-r--r--deskutils/recoll/files/patch-lib__Makefile11
1 files changed, 11 insertions, 0 deletions
diff --git a/deskutils/recoll/files/patch-lib__Makefile b/deskutils/recoll/files/patch-lib__Makefile
new file mode 100644
index 000000000000..633522051cb1
--- /dev/null
+++ b/deskutils/recoll/files/patch-lib__Makefile
@@ -0,0 +1,11 @@
+--- ./lib/Makefile.orig 2013-10-02 09:44:22.000000000 +0200
++++ ./lib/Makefile 2013-10-29 15:57:51.000000000 +0100
+@@ -19,7 +19,7 @@
+ # no effort whatsoever to maintain any kind of ABI compat in this lib. Only
+ # programs or modules from the same Recoll release can be compatible.
+ $(LIBRECOLL): $(DEPS) $(OBJS)
+- g++ -shared -Wl,--no-undefined -Wl,--warn-unresolved-symbols -Wl,-soname=$(LIBRECOLL) -o $(LIBRECOLL) $(OBJS) $(LIBXAPIAN) $(LIBICONV) $(X_LIBX11) $(LIBSYS)
++ $(CXX) -shared -Wl,--no-undefined -Wl,--warn-unresolved-symbols -Wl,-soname=$(LIBRECOLL) -o $(LIBRECOLL) $(OBJS) $(LIBXAPIAN) $(LIBICONV) $(X_LIBX11) $(LIBSYS)
+ rm -f librecoll.so
+ ln -s $(LIBRECOLL) librecoll.so
+