aboutsummaryrefslogtreecommitdiff
path: root/deskutils/xfce4-xkb-plugin
diff options
context:
space:
mode:
Diffstat (limited to 'deskutils/xfce4-xkb-plugin')
-rw-r--r--deskutils/xfce4-xkb-plugin/Makefile24
-rw-r--r--deskutils/xfce4-xkb-plugin/distinfo6
-rw-r--r--deskutils/xfce4-xkb-plugin/files/patch-panel-plugin::xkb.c15
-rw-r--r--deskutils/xfce4-xkb-plugin/pkg-descr2
-rw-r--r--deskutils/xfce4-xkb-plugin/pkg-plist24
5 files changed, 33 insertions, 38 deletions
diff --git a/deskutils/xfce4-xkb-plugin/Makefile b/deskutils/xfce4-xkb-plugin/Makefile
index 8b289e58a8b0..baf3557ca751 100644
--- a/deskutils/xfce4-xkb-plugin/Makefile
+++ b/deskutils/xfce4-xkb-plugin/Makefile
@@ -6,28 +6,22 @@
#
PORTNAME= xfce4-xkb-plugin
-PORTVERSION= 0.3.5
+PORTVERSION= 0.4.3
CATEGORIES= deskutils xfce
-MASTER_SITES= http://download.berlios.de/xfce-goodies/
+MASTER_SITES= http://goodies.xfce.org/releases/${PORTNAME}/
DIST_SUBDIR= xfce4
MAINTAINER= des@FreeBSD.org
COMMENT= Keyboard layout switching plugin for XFce4
-BUILD_DEPENDS= xfce4-panel:${PORTSDIR}/x11-wm/xfce4-panel
-LIB_DEPENDS= xfce4util.1:${PORTSDIR}/x11/libxfce4util \
- xfcegui4.3:${PORTSDIR}/x11-toolkits/libxfce4gui
-RUN_DEPENDS= xfce4-panel:${PORTSDIR}/x11-wm/xfce4-panel
-
-USE_GNOME= gtk20 libxml2
GNU_CONFIGURE= yes
-INSTALLS_SHLIB= yes
-CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
+USE_BZIP2= yes
+USE_GETTEXT= yes
+USE_GMAKE= yes
+USE_GNOME= gnometarget gtk20 intltool intlhack pkgconfig
+USE_XFCE= configenv panel
+USE_XLIB= yes
.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 500000
-BROKEN= does not compile
-.endif
-
+.include "${PORTSDIR}/x11-wm/xfce4/bsd.xfce.mk"
.include <bsd.port.post.mk>
diff --git a/deskutils/xfce4-xkb-plugin/distinfo b/deskutils/xfce4-xkb-plugin/distinfo
index 073afdc3ea2f..33e2d8120bed 100644
--- a/deskutils/xfce4-xkb-plugin/distinfo
+++ b/deskutils/xfce4-xkb-plugin/distinfo
@@ -1,3 +1,3 @@
-MD5 (xfce4/xfce4-xkb-plugin-0.3.5.tar.gz) = 0c92dd17579e102b40289c4bc83c5505
-SHA256 (xfce4/xfce4-xkb-plugin-0.3.5.tar.gz) = 769d4b337200b2dead8fc23d4fb394bacde551cb07a504acc68e160891cd8c18
-SIZE (xfce4/xfce4-xkb-plugin-0.3.5.tar.gz) = 353851
+MD5 (xfce4/xfce4-xkb-plugin-0.4.3.tar.bz2) = e0375158339672f49c9e48a8b4669592
+SHA256 (xfce4/xfce4-xkb-plugin-0.4.3.tar.bz2) = e72983cf53450caa0a755838b61e867b599f2302d08d3ad28662ed6391152f7e
+SIZE (xfce4/xfce4-xkb-plugin-0.4.3.tar.bz2) = 231843
diff --git a/deskutils/xfce4-xkb-plugin/files/patch-panel-plugin::xkb.c b/deskutils/xfce4-xkb-plugin/files/patch-panel-plugin::xkb.c
deleted file mode 100644
index 7d72d7b174c1..000000000000
--- a/deskutils/xfce4-xkb-plugin/files/patch-panel-plugin::xkb.c
+++ /dev/null
@@ -1,15 +0,0 @@
---- panel-plugin/xkb.c.orig Wed Jun 30 11:46:49 2004
-+++ panel-plugin/xkb.c Sun Feb 6 12:51:04 2005
-@@ -264,12 +264,12 @@
- char *group;
-
- group = strdup(get_symbol_name_by_res_no(current_group_xkb_no));
-+ to_lower(group);
- strcpy(filename, FLAGSDIR);
- strcat(filename, "/");
- strcat(filename, group);
- strcat(filename, ".png");
-- to_lower(filename);
-
- free(group);
-
diff --git a/deskutils/xfce4-xkb-plugin/pkg-descr b/deskutils/xfce4-xkb-plugin/pkg-descr
index 9b7a77210aad..a879e01abe9d 100644
--- a/deskutils/xfce4-xkb-plugin/pkg-descr
+++ b/deskutils/xfce4-xkb-plugin/pkg-descr
@@ -9,4 +9,4 @@ This plugin is used along with the XKB extension. For now the keyboard
layouts cannot be configured from the plugin itself, they should be
set in the XF86Config file or some other way (e.g. setxkbmap).
-WWW: http://xfce-goodies.berlios.de/
+WWW: http://goodies.xfce.org/projects/panel-plugins/xfce4-xkb-plugin
diff --git a/deskutils/xfce4-xkb-plugin/pkg-plist b/deskutils/xfce4-xkb-plugin/pkg-plist
index cecce9621b1c..3433f87c2ddd 100644
--- a/deskutils/xfce4-xkb-plugin/pkg-plist
+++ b/deskutils/xfce4-xkb-plugin/pkg-plist
@@ -1,6 +1,18 @@
-lib/xfce4/panel-plugins/libxkb.a
-lib/xfce4/panel-plugins/libxkb.la
-lib/xfce4/panel-plugins/libxkb.so
+libexec/xfce4/panel-plugins/xfce4-xkb-plugin
+share/locale/bg/LC_MESSAGES/xfce4-xkb-plugin.mo
+share/locale/de/LC_MESSAGES/xfce4-xkb-plugin.mo
+share/locale/eu/LC_MESSAGES/xfce4-xkb-plugin.mo
+share/locale/fr/LC_MESSAGES/xfce4-xkb-plugin.mo
+share/locale/hu/LC_MESSAGES/xfce4-xkb-plugin.mo
+share/locale/ru/LC_MESSAGES/xfce4-xkb-plugin.mo
+share/locale/ca/LC_MESSAGES/xfce4-xkb-plugin.mo
+share/locale/cs/LC_MESSAGES/xfce4-xkb-plugin.mo
+share/locale/el/LC_MESSAGES/xfce4-xkb-plugin.mo
+share/locale/gl/LC_MESSAGES/xfce4-xkb-plugin.mo
+share/locale/ja/LC_MESSAGES/xfce4-xkb-plugin.mo
+share/locale/pl/LC_MESSAGES/xfce4-xkb-plugin.mo
+share/locale/zh_TW/LC_MESSAGES/xfce4-xkb-plugin.mo
+share/xfce4/panel-plugins/xkb-plugin.desktop
share/xfce4/xkb/flags/ae.png
share/xfce4/xkb/flags/am.png
share/xfce4/xkb/flags/ar.png
@@ -21,12 +33,12 @@ share/xfce4/xkb/flags/dk.png
share/xfce4/xkb/flags/dz.png
share/xfce4/xkb/flags/ee.png
share/xfce4/xkb/flags/eg.png
-share/xfce4/xkb/flags/el.png
share/xfce4/xkb/flags/es.png
share/xfce4/xkb/flags/eu.png
share/xfce4/xkb/flags/fi.png
share/xfce4/xkb/flags/fr.png
share/xfce4/xkb/flags/ge.png
+share/xfce4/xkb/flags/gr.png
share/xfce4/xkb/flags/hr.png
share/xfce4/xkb/flags/hu.png
share/xfce4/xkb/flags/il.png
@@ -75,6 +87,10 @@ share/xfce4/xkb/flags/uy.png
share/xfce4/xkb/flags/vn.png
share/xfce4/xkb/flags/ye.png
share/xfce4/xkb/flags/yu.png
+@dirrmtry libexec/xfce4/panel-plugins
+@dirrmtry libexec/xfce4
+@dirrmtry share/xfce4/panel-plugins
+@dirrmtry share/xfce4
@dirrm share/xfce4/xkb/flags
@dirrm share/xfce4/xkb
@dirrmtry share/xfce4