aboutsummaryrefslogtreecommitdiff
path: root/deskutils
diff options
context:
space:
mode:
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/kcharselect/Makefile8
-rw-r--r--deskutils/kcharselect/distinfo4
-rw-r--r--deskutils/kcharselect/files/patch-ark-CMakeLists.txt26
-rw-r--r--deskutils/kcharselect/files/patch-ark-plugins-CMakeLists.txt32
-rw-r--r--deskutils/kdepimlibs4/distinfo4
-rw-r--r--deskutils/kdeplasma-addons/Makefile2
-rw-r--r--deskutils/kdeplasma-addons/distinfo4
7 files changed, 68 insertions, 12 deletions
diff --git a/deskutils/kcharselect/Makefile b/deskutils/kcharselect/Makefile
index 0a7c286315db..9a66faa99cad 100644
--- a/deskutils/kcharselect/Makefile
+++ b/deskutils/kcharselect/Makefile
@@ -33,6 +33,9 @@ MAKE_JOBS_SAFE= yes
MAN1= ark.1
+# Disable printer-applet, it comes with print/kdeutils4-printer-applet.
+CMAKE_ARGS+= -DBUILD_printer-applet=OFF
+
OPTIONS= 7ZIP "Support for 7-Zip archives in Ark" off \
PRINTER_APPLET "Install printer system tray utility" off \
RAR "Support for RAR archives in Ark" off \
@@ -76,9 +79,4 @@ RUN_DEPENDS+= rar:${PORTSDIR}/archivers/rar
.endif
.endif
-post-patch:
-# Disable printer-applet, it comes with print/kdeutils4-printer-applet.
- ${REINPLACE_CMD} -e '/add_subdirectory.*printer-applet/d' \
- ${PATCH_WRKSRC}/CMakeLists.txt
-
.include <bsd.port.post.mk>
diff --git a/deskutils/kcharselect/distinfo b/deskutils/kcharselect/distinfo
index 67cad0f38a7b..824077cfc83b 100644
--- a/deskutils/kcharselect/distinfo
+++ b/deskutils/kcharselect/distinfo
@@ -1,2 +1,2 @@
-SHA256 (KDE/kdeutils-4.6.2.tar.bz2) = d1a2d77fe51fe6fb3c9eb79408b7d617927e0e12a0e6d34d2b21cd087d9afbeb
-SIZE (KDE/kdeutils-4.6.2.tar.bz2) = 3703067
+SHA256 (KDE/kdeutils-4.6.3.tar.bz2) = d61e97a5b3464fbfaef624927cfc19da4158dd91f2e020eb245d10da8af33196
+SIZE (KDE/kdeutils-4.6.3.tar.bz2) = 3703326
diff --git a/deskutils/kcharselect/files/patch-ark-CMakeLists.txt b/deskutils/kcharselect/files/patch-ark-CMakeLists.txt
new file mode 100644
index 000000000000..fae223ae2a40
--- /dev/null
+++ b/deskutils/kcharselect/files/patch-ark-CMakeLists.txt
@@ -0,0 +1,26 @@
+KDE SVN revision r1230915.
+
+Author: rkcosta (Raphael Kubo da Costa)
+Date: Sun May 8 17:30:06 2011 +0000
+
+ Put the libarchive detection calls before configure_file().
+
+ The generated config.h was using some variables defined only after
+ plugins/CMakeLists.txt called macro_optional_find_package(LibArchive),
+ however the top-level CMakeLists.txt relied on these variables already
+ being set, which was never the case.
+
+ BUG: 271553
+ FIXED-IN: 4.6.4
+
+--- ark/CMakeLists.txt
++++ ark/CMakeLists.txt
+@@ -1,5 +1,8 @@
+ project(ark)
+
++macro_optional_find_package(LibArchive)
++macro_log_feature(LIBARCHIVE_FOUND "LibArchive" "A library for dealing with a wide variety of archive file formats" "http://code.google.com/p/libarchive/" FALSE "" "Required for among others tar, tar.gz, tar.bz2 formats in Ark.")
++
+ configure_file(config.h.cmake ${CMAKE_CURRENT_BINARY_DIR}/config.h)
+
+ add_subdirectory(part)
diff --git a/deskutils/kcharselect/files/patch-ark-plugins-CMakeLists.txt b/deskutils/kcharselect/files/patch-ark-plugins-CMakeLists.txt
new file mode 100644
index 000000000000..f157bf403124
--- /dev/null
+++ b/deskutils/kcharselect/files/patch-ark-plugins-CMakeLists.txt
@@ -0,0 +1,32 @@
+KDE SVN revision r1230915.
+
+Author: rkcosta (Raphael Kubo da Costa)
+Date: Sun May 8 17:30:06 2011 +0000
+
+ Put the libarchive detection calls before configure_file().
+
+ The generated config.h was using some variables defined only after
+ plugins/CMakeLists.txt called macro_optional_find_package(LibArchive),
+ however the top-level CMakeLists.txt relied on these variables already
+ being set, which was never the case.
+
+ BUG: 271553
+ FIXED-IN: 4.6.4
+
+--- ark/plugins/CMakeLists.txt
++++ ark/plugins/CMakeLists.txt
+@@ -1,5 +1,3 @@
+-macro_optional_find_package(LibArchive)
+-
+ if (LIBARCHIVE_FOUND)
+ if( HAVE_LIBARCHIVE_READ_DISK_API )
+ if( NOT HAVE_LIBARCHIVE_LZMA_SUPPORT OR NOT HAVE_LIBARCHIVE_XZ_SUPPORT )
+@@ -15,8 +13,6 @@ if (LIBARCHIVE_FOUND)
+ endif( HAVE_LIBARCHIVE_READ_DISK_API )
+ endif (LIBARCHIVE_FOUND)
+
+-macro_log_feature(LIBARCHIVE_FOUND "LibArchive" "A library for dealing with a wide variety of archive file formats" "http://code.google.com/p/libarchive/" FALSE "" "Required for among others tar, tar.gz, tar.bz2 formats in Ark.")
+-
+ add_subdirectory( clirarplugin )
+ add_subdirectory( cli7zplugin )
+ add_subdirectory( clizipplugin )
diff --git a/deskutils/kdepimlibs4/distinfo b/deskutils/kdepimlibs4/distinfo
index 0e560031241e..3c9251a9aafe 100644
--- a/deskutils/kdepimlibs4/distinfo
+++ b/deskutils/kdepimlibs4/distinfo
@@ -1,2 +1,2 @@
-SHA256 (KDE/kdepimlibs-4.6.2.tar.bz2) = fcadf219183658c519cdbd73ec1c7d9d7bc7c7de85afa2302f96555b430a41c4
-SIZE (KDE/kdepimlibs-4.6.2.tar.bz2) = 3198990
+SHA256 (KDE/kdepimlibs-4.6.3.tar.bz2) = abac2ce510f16f0614be6bb07e11f979f427981f17ab674951510c83ea72b95d
+SIZE (KDE/kdepimlibs-4.6.3.tar.bz2) = 3202266
diff --git a/deskutils/kdeplasma-addons/Makefile b/deskutils/kdeplasma-addons/Makefile
index 3ef98e4c7bb9..32d8f8805810 100644
--- a/deskutils/kdeplasma-addons/Makefile
+++ b/deskutils/kdeplasma-addons/Makefile
@@ -16,7 +16,7 @@ MAINTAINER= kde@FreeBSD.org
COMMENT= Extra plasmoids for KDE4
BUILD_DEPENDS= eigen>=2.0.b3:${PORTSDIR}/math/eigen2
-LIB_DEPENDS= kipi.8:${PORTSDIR}/graphics/kdegraphics4 \
+LIB_DEPENDS= kexiv2:${PORTSDIR}/graphics/kdegraphics4 \
qalculate.5:${PORTSDIR}/math/libqalculate \
qwt.5:${PORTSDIR}/x11-toolkits/qwt5 \
marblewidget.11:${PORTSDIR}/astro/marble
diff --git a/deskutils/kdeplasma-addons/distinfo b/deskutils/kdeplasma-addons/distinfo
index b7d630918a72..5fd7f1698741 100644
--- a/deskutils/kdeplasma-addons/distinfo
+++ b/deskutils/kdeplasma-addons/distinfo
@@ -1,2 +1,2 @@
-SHA256 (KDE/kdeplasma-addons-4.6.2.tar.bz2) = c8741cbecb071d2d00c686e48e2076c51d1013efe3ac791b74219f2dd8446a6d
-SIZE (KDE/kdeplasma-addons-4.6.2.tar.bz2) = 1912053
+SHA256 (KDE/kdeplasma-addons-4.6.3.tar.bz2) = 6f8c11191aecb7cd8477c3c406515dc13991c4f6f73b892c0e25e89b12e58bcf
+SIZE (KDE/kdeplasma-addons-4.6.3.tar.bz2) = 1935272