aboutsummaryrefslogtreecommitdiff
path: root/deskutils
diff options
context:
space:
mode:
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/kdepim3/Makefile8
-rw-r--r--deskutils/kdepim4/Makefile8
-rw-r--r--deskutils/kdepim44/Makefile8
3 files changed, 18 insertions, 6 deletions
diff --git a/deskutils/kdepim3/Makefile b/deskutils/kdepim3/Makefile
index 6a05acaa13a3..90a18a3ec540 100644
--- a/deskutils/kdepim3/Makefile
+++ b/deskutils/kdepim3/Makefile
@@ -7,7 +7,7 @@
PORTNAME= kdepim
PORTVERSION= ${KDE_VERSION}
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= deskutils mail news palm kde
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= stable/${PORTVERSION:S/.0//}/src
@@ -65,8 +65,12 @@ pre-everything::
@${ECHO_MSG}
.endif
+.if ${OSVERSION} >= 501111 && !defined(NO_BLUETOOTH)
+_LBLUETOOTH= -lbluetooth
+.endif
+
pre-configure:
${REINPLACE_CMD} -e 's|-ldl||' ${WRKSRC}/configure
- ${REINPLACE_CMD} -e 's|-lgnokii|-lgnokii -liconv -lintl|' ${WRKSRC}/configure
+ ${REINPLACE_CMD} -e 's|-lgnokii|-lgnokii -liconv -lintl ${_LBLUETOOTH}|' ${WRKSRC}/configure
.include <bsd.port.post.mk>
diff --git a/deskutils/kdepim4/Makefile b/deskutils/kdepim4/Makefile
index 6a05acaa13a3..90a18a3ec540 100644
--- a/deskutils/kdepim4/Makefile
+++ b/deskutils/kdepim4/Makefile
@@ -7,7 +7,7 @@
PORTNAME= kdepim
PORTVERSION= ${KDE_VERSION}
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= deskutils mail news palm kde
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= stable/${PORTVERSION:S/.0//}/src
@@ -65,8 +65,12 @@ pre-everything::
@${ECHO_MSG}
.endif
+.if ${OSVERSION} >= 501111 && !defined(NO_BLUETOOTH)
+_LBLUETOOTH= -lbluetooth
+.endif
+
pre-configure:
${REINPLACE_CMD} -e 's|-ldl||' ${WRKSRC}/configure
- ${REINPLACE_CMD} -e 's|-lgnokii|-lgnokii -liconv -lintl|' ${WRKSRC}/configure
+ ${REINPLACE_CMD} -e 's|-lgnokii|-lgnokii -liconv -lintl ${_LBLUETOOTH}|' ${WRKSRC}/configure
.include <bsd.port.post.mk>
diff --git a/deskutils/kdepim44/Makefile b/deskutils/kdepim44/Makefile
index 6a05acaa13a3..90a18a3ec540 100644
--- a/deskutils/kdepim44/Makefile
+++ b/deskutils/kdepim44/Makefile
@@ -7,7 +7,7 @@
PORTNAME= kdepim
PORTVERSION= ${KDE_VERSION}
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= deskutils mail news palm kde
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= stable/${PORTVERSION:S/.0//}/src
@@ -65,8 +65,12 @@ pre-everything::
@${ECHO_MSG}
.endif
+.if ${OSVERSION} >= 501111 && !defined(NO_BLUETOOTH)
+_LBLUETOOTH= -lbluetooth
+.endif
+
pre-configure:
${REINPLACE_CMD} -e 's|-ldl||' ${WRKSRC}/configure
- ${REINPLACE_CMD} -e 's|-lgnokii|-lgnokii -liconv -lintl|' ${WRKSRC}/configure
+ ${REINPLACE_CMD} -e 's|-lgnokii|-lgnokii -liconv -lintl ${_LBLUETOOTH}|' ${WRKSRC}/configure
.include <bsd.port.post.mk>