aboutsummaryrefslogtreecommitdiff
path: root/deskutils
diff options
context:
space:
mode:
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/Makefile1
-rw-r--r--deskutils/dlume/Makefile24
-rw-r--r--deskutils/dlume/distinfo1
-rw-r--r--deskutils/dlume/pkg-descr8
-rw-r--r--deskutils/dlume/pkg-plist1
5 files changed, 35 insertions, 0 deletions
diff --git a/deskutils/Makefile b/deskutils/Makefile
index 4331193e97f6..a9449fd610e7 100644
--- a/deskutils/Makefile
+++ b/deskutils/Makefile
@@ -10,6 +10,7 @@
SUBDIR += cbb
SUBDIR += checkrdf
SUBDIR += dailystrips
+ SUBDIR += dlume
SUBDIR += dragstack
SUBDIR += gaddr
SUBDIR += gcal
diff --git a/deskutils/dlume/Makefile b/deskutils/dlume/Makefile
new file mode 100644
index 000000000000..737dc7c83df0
--- /dev/null
+++ b/deskutils/dlume/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: dlume
+# Date created: 07 November 2003
+# Whom: Adam Weinberger <adamw@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= dlume
+PORTVERSION= 0.1.0
+CATEGORIES= deskutils gnome
+MASTER_SITES= http://clay.ll.pl/download/
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= GTK2 address book
+
+USE_X_PREFIX= yes
+GNU_CONFIGURE= yes
+USE_GNOME= gnomehack gnomeprefix gtk20
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LIBS="-L${LOCALBASE}/lib"
+
+MAN1= ${PORTNAME}.1
+
+.include <bsd.port.mk>
diff --git a/deskutils/dlume/distinfo b/deskutils/dlume/distinfo
new file mode 100644
index 000000000000..852a781af412
--- /dev/null
+++ b/deskutils/dlume/distinfo
@@ -0,0 +1 @@
+MD5 (dlume-0.1.0.tar.gz) = 3306e14b3903aa28128d07a5c40a05c9
diff --git a/deskutils/dlume/pkg-descr b/deskutils/dlume/pkg-descr
new file mode 100644
index 000000000000..a0836f035820
--- /dev/null
+++ b/deskutils/dlume/pkg-descr
@@ -0,0 +1,8 @@
+Dlume is nice, gtk2-based addressbook. You can easily add, edit
+and delete records to/from database (but Dlume doesn't rely on an outside
+database - It stores your contacts in XML format). The Quick-search
+feature allows you find required entry in comfortable way. Export to
+CSV and HTML formats is also available. Interface design was borrowed
+and improved from Paddress (http://paddress.sourceforge.net).
+
+WWW: http://clay.ll.pl/projects.html
diff --git a/deskutils/dlume/pkg-plist b/deskutils/dlume/pkg-plist
new file mode 100644
index 000000000000..cd4b26358e5e
--- /dev/null
+++ b/deskutils/dlume/pkg-plist
@@ -0,0 +1 @@
+bin/dlume