aboutsummaryrefslogtreecommitdiff
path: root/devel/ada-util/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/ada-util/Makefile')
-rw-r--r--devel/ada-util/Makefile15
1 files changed, 15 insertions, 0 deletions
diff --git a/devel/ada-util/Makefile b/devel/ada-util/Makefile
index 0e5b6d92d452..c097f9df34a4 100644
--- a/devel/ada-util/Makefile
+++ b/devel/ada-util/Makefile
@@ -3,6 +3,7 @@
PORTNAME= ada-util
PORTVERSION= 1.8.0
+PORTREVISION= 1
CATEGORIES= devel
MAINTAINER= marino@FreeBSD.org
@@ -37,6 +38,20 @@ post-patch:
@${REINPLACE_CMD} -e '/Content_Type/d' \
${WRKSRC}/src/http/util-http-rest.adb
+ # Loggers are hardcoded for several packages at the INFO level
+ # which is quite useless for things like spawning commands.
+ # Set the loggers to filter out everything up less than ERROR
+
+ @${REINPLACE_CMD} -e '/Loggers.Create/s|);|, Util.Log.ERROR_LEVEL);|'\
+ ${WRKSRC}/src/http/aws/util-http-clients-web.adb \
+ ${WRKSRC}/src/http/curl/util-http-clients-curl.adb \
+ ${WRKSRC}/src/http/util-http-clients.adb \
+ ${WRKSRC}/src/http/util-http-parts.adb \
+ ${WRKSRC}/src/util-beans-factory.adb \
+ ${WRKSRC}/src/util-processes.adb \
+ ${WRKSRC}/src/util-properties-bundles.adb \
+ ${WRKSRC}/src/xml/util-serialize-io-xml.adb
+
post-install:
${RM} -r ${STAGEDIR}${PREFIX}/lib/gnat/manifests