aboutsummaryrefslogtreecommitdiff
path: root/devel/allegro-devel/files
diff options
context:
space:
mode:
Diffstat (limited to 'devel/allegro-devel/files')
-rw-r--r--devel/allegro-devel/files/patch-aclocal.m414
-rw-r--r--devel/allegro-devel/files/patch-configure.in20
-rw-r--r--devel/allegro-devel/files/patch-makefile.in32
3 files changed, 28 insertions, 38 deletions
diff --git a/devel/allegro-devel/files/patch-aclocal.m4 b/devel/allegro-devel/files/patch-aclocal.m4
index 45dc3fe47e5d..8c274f2926df 100644
--- a/devel/allegro-devel/files/patch-aclocal.m4
+++ b/devel/allegro-devel/files/patch-aclocal.m4
@@ -1,11 +1,11 @@
---- aclocal.m4.orig Thu Feb 7 19:52:21 2002
-+++ aclocal.m4 Thu Feb 7 19:52:45 2002
-@@ -181,7 +181,7 @@
- LDFLAGS="$allegro_save_LDFLAGS"])
- if test $allegro_cv_support_export_dynamic = yes; then
+--- aclocal.m4.orig Tue Oct 22 00:17:38 2002
++++ aclocal.m4 Tue Oct 22 00:17:55 2002
+@@ -183,7 +183,7 @@
allegro_support_modules=yes
-- LIBS="-ldl $LIBS"
-+ LIBS="$LIBS"
+ dnl Use libdl if found, else assume dl* functions in libc.
+ AC_CHECK_LIB(dl, dlopen,
+- [LIBS="-ldl $LIBS"])
++ [LIBS="$LIBS"])
LDFLAGS="-Wl,-export-dynamic $LDFLAGS"
fi])
fi
diff --git a/devel/allegro-devel/files/patch-configure.in b/devel/allegro-devel/files/patch-configure.in
index d71c977159a8..5bfe99de32eb 100644
--- a/devel/allegro-devel/files/patch-configure.in
+++ b/devel/allegro-devel/files/patch-configure.in
@@ -1,9 +1,11 @@
---- configure.in.orig Wed Feb 13 22:27:04 2002
-+++ configure.in Wed Feb 13 22:27:10 2002
-@@ -498,5 +498,5 @@
-
- dnl Run "make depend" if necessary.
- if test "X$allegro_make_depend" = "Xyes"; then
-- make depend
-+ ${MAKE} depend
- fi
+--- configure.in.orig Tue Oct 22 00:18:10 2002
++++ configure.in Tue Oct 22 00:20:03 2002
+@@ -504,7 +504,7 @@
+ ${MAKE-make} depend
+ else
+ AC_MSG_WARN([Non-GNU make detected, trying gmake to build dependencies.])
+- gmake depend
++ ${MAKE-make} depend
+ AC_MSG_WARN([You need to use GNU make to build Allegro.])
+ AC_MSG_WARN([This might be called gmake on your system.])
+ fi
diff --git a/devel/allegro-devel/files/patch-makefile.in b/devel/allegro-devel/files/patch-makefile.in
index d62d72d642ac..36e512e4f03c 100644
--- a/devel/allegro-devel/files/patch-makefile.in
+++ b/devel/allegro-devel/files/patch-makefile.in
@@ -1,47 +1,44 @@
---- makefile.in.orig Mon Dec 10 11:37:39 2001
-+++ makefile.in Thu Feb 14 08:59:06 2002
+--- makefile.in.orig Thu Jul 4 04:20:02 2002
++++ makefile.in Tue Oct 22 00:31:27 2002
@@ -31,7 +31,7 @@
ACLOCAL = aclocal
ACLOCAL_M4 = $(srcdir)/aclocal.m4
AUTOCONF = autoconf
-AUTOHEADER = autoheader
-+AUTOHEADER =autoheader213
++AUTOHEADER = autoheader213
INSTALL = @INSTALL@
INSTALL_PROGRAM = @INSTALL_PROGRAM@
-@@ -323,18 +323,19 @@
+@@ -347,17 +347,17 @@
fi
$(mkinstalldirs) $(bindir)
@echo Installing allegro-config to $(bindir)
- @$(INSTALL_PROGRAM) allegro-config $(bindir)
- @if test -n "$(LIBDIR)/liball*-$(shared_version).so"; then \
-- (grep -q $(libdir) /etc/ld.so.conf || \
+- (cat /etc/ld.so.conf | grep $(libdir) >/dev/null || \
- test $(libdir) = /lib || test $(libdir) = /usr/lib) \
- && ($(LDCONFIG) $(libdir) || true) || (\
- echo "" ; \
- echo "Warning: shared library destination $(libdir) is not in ldd search path." ; \
- echo "Unless you add it to /etc/ld.so.conf, you must set LD_LIBRARY_PATH to include"; \
- echo "$(libdir) each time you want to run an Allegro program." ; \
-- $(LDCONFIG) -n $(libdir) ; \
- ) ; \
- fi
+ @$(INSTALL) allegro-config $(bindir)
-+# Don't worry about this,
+# @if test -n "$(LIBDIR)/liball*-$(shared_version).so"; then \
-+# (grep -q $(libdir) /etc/ld.so.conf || \
++# (cat /etc/ld.so.conf | grep $(libdir) >/dev/null || \
+# test $(libdir) = /lib || test $(libdir) = /usr/lib) \
+# && ($(LDCONFIG) $(libdir) || true) || (\
+# echo "" ; \
+# echo "Warning: shared library destination $(libdir) is not in ldd search path." ; \
+# echo "Unless you add it to /etc/ld.so.conf, you must set LD_LIBRARY_PATH to include"; \
+# echo "$(libdir) each time you want to run an Allegro program." ; \
-+# $(LDCONFIG) $(libdir) ; \
+# ) ; \
+# fi
-
- install-headers:
- $(mkinstalldirs) $(includedir)/allegro
-@@ -367,7 +368,7 @@
+ @for l in alleg alld allp; do \
+ if test -f $(libdir)/lib$${l}-$(shared_version).so -a \! -L $(libdir)/lib$${l}.so.${shared_major_minor}; then \
+ (cd $(libdir); ln -s lib$${l}-$(shared_version).so lib$${l}.so.${shared_major_minor}); \
+@@ -395,7 +395,7 @@
@for prog in $(ALLEGRO_LIB_EXES) $(ALLEGRO_DATAFILE_EXES); do \
if test "X`echo $$prog | sed -e s,tools/.\*,,`" = X; then \
echo Installing $$prog to $(bindir); \
@@ -50,12 +47,3 @@
fi; \
done
-@@ -424,7 +425,7 @@
- @for l in alleg alld allp; do \
- rm -f $(libdir)/lib$${l}-${shared_version}.so; \
- done
-- $(LDCONFIG) -n $(libdir) # remove symlinks
-+ $(LDCONFIG) $(libdir) # remove symlinks
- -$(LDCONFIG) $(libdir) # update cache (only works if we're root)
-
- uninstall-modules: