aboutsummaryrefslogtreecommitdiff
path: root/devel/anjuta-devel/files
diff options
context:
space:
mode:
Diffstat (limited to 'devel/anjuta-devel/files')
-rw-r--r--devel/anjuta-devel/files/patch-Makefile.in29
-rw-r--r--devel/anjuta-devel/files/patch-configure39
-rw-r--r--devel/anjuta-devel/files/patch-src-Makefile.in147
-rw-r--r--devel/anjuta-devel/files/patch-src::anjuta.c14
4 files changed, 87 insertions, 142 deletions
diff --git a/devel/anjuta-devel/files/patch-Makefile.in b/devel/anjuta-devel/files/patch-Makefile.in
index a3e2e54bd17d..c863c25da036 100644
--- a/devel/anjuta-devel/files/patch-Makefile.in
+++ b/devel/anjuta-devel/files/patch-Makefile.in
@@ -1,15 +1,28 @@
---- Makefile.in.orig Sun Aug 12 11:01:09 2001
-+++ Makefile.in Sun Aug 12 11:02:14 2001
-@@ -128,10 +128,10 @@
+
+$FreeBSD$
+
+--- Makefile.in.orig Fri Jan 4 16:09:11 2002
++++ Makefile.in Fri Jan 4 16:26:58 2002
+@@ -137,11 +137,11 @@
cxxflags_set = @cxxflags_set@
l = @l@
--SUBDIRS = intl po macros scintilla ccview widgets manuals omf-install src pixmaps data doc launcher
-+SUBDIRS = intl po macros ccview widgets manuals omf-install src pixmaps data doc launcher
+-SUBDIRS = intl po macros tagmanager global-tags scintilla ccview widgets manuals omf-install src pixmaps data doc launcher
++SUBDIRS = intl po macros tagmanager global-tags ccview widgets manuals omf-install src pixmaps data launcher
+
anjutadocdir = ${prefix}/doc/anjuta
--anjutadoc_DATA = README COPYING AUTHORS ChangeLog INSTALL NEWS TODO ABOUT-NLS
-+anjutadoc_DATA =
+-anjutadoc_DATA = README COPYING AUTHORS ChangeLog INSTALL NEWS TODO ABOUT-NLS FUTURE
++anjutadoc_DATA = # README COPYING AUTHORS ChangeLog INSTALL NEWS TODO ABOUT-NLS FUTURE
+
+
+ EXTRA_DIST = anjuta.desktop.in.in anjuta.spec.in xml-i18n-extract.in xml-i18n-merge.in xml-i18n-update.in $(anjutadoc_DATA)
+@@ -416,7 +416,7 @@
+ install-exec-am:
+ install-exec: install-exec-recursive
+-install-data-am: install-anjutadocDATA install-gnomemenuDATA
++install-data-am: install-gnomemenuDATA
+ install-data: install-data-recursive
- EXTRA_DIST = anjuta.desktop.in.in anjuta.prj anjuta.spec.in xml-i18n-extract.in xml-i18n-merge.in xml-i18n-update.in $(anjutadoc_DATA)
+ install-am: all-am
diff --git a/devel/anjuta-devel/files/patch-configure b/devel/anjuta-devel/files/patch-configure
index 7de922948ecf..7bf2e921a144 100644
--- a/devel/anjuta-devel/files/patch-configure
+++ b/devel/anjuta-devel/files/patch-configure
@@ -1,5 +1,8 @@
---- configure.orig Fri Aug 24 12:34:57 2001
-+++ configure Fri Aug 24 12:35:13 2001
+
+$FreeBSD$
+
+--- configure.orig Fri Jan 4 15:39:12 2002
++++ configure Fri Jan 4 16:07:50 2002
@@ -8,6 +8,7 @@
# gives unlimited permission to copy, distribute and modify it.
@@ -8,10 +11,24 @@
ac_help=
ac_default_prefix=/usr/local
# Any additions from configure.in:
-@@ -4812,12 +4813,10 @@
- intl/Makefile
- po/Makefile.in
- macros/Makefile
+@@ -6391,10 +6392,10 @@
+ packageprefix=${prefix}
+ fi
+
+-packagedatadir=share/${PACKAGE}
+-packagedocdir=doc/${PACKAGE}
++packagedatadir=share/gnome/${PACKAGE}
++packagedocdir=share/doc/${PACKAGE}
+
+-packagepixmapsdir=share/pixmaps/${PACKAGE}
++packagepixmapsdir=share/gnome/pixmaps/${PACKAGE}
+ packagehelpdir=share/gnome/help/${PACKAGE}
+ packagemenudir=share/gnome/apps
+
+@@ -6557,12 +6558,10 @@
+ tagmanager/Makefile
+ tagmanager/include/Makefile
+ global-tags/Makefile
-scintilla/Makefile
ccview/Makefile
widgets/Makefile
@@ -21,7 +38,7 @@
manuals/C/Makefile
manuals/C/anjuta-manual/Makefile
manuals/C/anjuta-faqs/Makefile
-@@ -4906,6 +4905,7 @@
+@@ -6656,6 +6655,7 @@
s%@GNOME_CAPPLET_LIBS@%$GNOME_CAPPLET_LIBS%g
s%@cflags_set@%$cflags_set%g
s%@GTK_CONFIG@%$GTK_CONFIG%g
@@ -29,10 +46,10 @@
s%@GTK_CFLAGS@%$GTK_CFLAGS%g
s%@GTK_LIBS@%$GTK_LIBS%g
s%@XPM_LIBS@%$XPM_LIBS%g
-@@ -4997,12 +4997,10 @@
- intl/Makefile
- po/Makefile.in
- macros/Makefile
+@@ -6759,12 +6759,10 @@
+ tagmanager/Makefile
+ tagmanager/include/Makefile
+ global-tags/Makefile
-scintilla/Makefile
ccview/Makefile
widgets/Makefile
diff --git a/devel/anjuta-devel/files/patch-src-Makefile.in b/devel/anjuta-devel/files/patch-src-Makefile.in
index d53028b77864..2f0fd8759a78 100644
--- a/devel/anjuta-devel/files/patch-src-Makefile.in
+++ b/devel/anjuta-devel/files/patch-src-Makefile.in
@@ -1,133 +1,34 @@
---- src/Makefile.in.orig Fri Aug 24 12:05:50 2001
-+++ src/Makefile.in Fri Aug 24 12:09:03 2001
-@@ -128,7 +128,7 @@
- cxxflags_set = @cxxflags_set@
- l = @l@
+
+$FreeBSD$
+
+--- src/Makefile.in.orig Fri Jan 4 15:15:40 2002
++++ src/Makefile.in Fri Jan 4 15:15:54 2002
+@@ -139,10 +139,10 @@
--INCLUDES = -I$(top_srcdir)/intl $(GNOME_INCLUDEDIR) -I$(srcdir)/../scintilla/include -I$(srcdir)/../widgets -I$(srcdir)/../ccview -I$(srcdir)/../pixmaps -I.. -I. -DHAVE_CONFIG_H -Wall -Wimplicit -Wreturn-type -Wunused -Wswitch -Wcomment -Wuninitialized -Wparentheses -Wtraditional -Wpointer-arith -Wmissing-prototypes -O1 -g
-+INCLUDES = -I$(top_srcdir)/intl $(GNOME_INCLUDEDIR) -I$(prefix)/include/scintilla -I$(srcdir)/../widgets -I$(srcdir)/../ccview -I$(srcdir)/../pixmaps -I.. -I. -DHAVE_CONFIG_H -Wall -Wimplicit -Wreturn-type -Wunused -Wswitch -Wcomment -Wuninitialized -Wparentheses -Wtraditional -Wpointer-arith -Wmissing-prototypes
+ EXTRA_DIST = glades.h Prj-skelimpl.c Prj-skels.c Prj-stubs.c
+-INCLUDES = -I$(top_srcdir)/intl $(GNOME_INCLUDEDIR) $(EXTRA_GNOME_CFLAGS) $(EXTRA_ORBIT_CFLAGS) -I$(srcdir)/../scintilla/include -I$(srcdir)/../tagmanager/include -I$(srcdir)/../widgets -I$(srcdir)/../ccview -I$(srcdir)/../pixmaps -I.. -I. -Wall -Wimplicit -Wreturn-type -Wunused -Wswitch -Wcomment -Wuninitialized -Wparentheses -Wpointer-arith -Wmissing-prototypes -O1 -g
++INCLUDES = -I$(top_srcdir)/intl $(GNOME_INCLUDEDIR) $(EXTRA_GNOME_CFLAGS) $(EXTRA_ORBIT_CFLAGS) -I$(prefix)/include/scintilla -I$(srcdir)/../tagmanager/include -I$(srcdir)/../widgets -I$(srcdir)/../ccview -I$(srcdir)/../pixmaps -I.. -I. -Wall -Wimplicit -Wreturn-type -Wunused -Wswitch -Wcomment -Wuninitialized -Wparentheses -Wpointer-arith -Wmissing-prototypes
- bin_PROGRAMS = anjuta
-@@ -136,7 +136,7 @@
- anjuta_SOURCES = aneditor.cxx aneditor.h anjuta.h anjuta_cbs.c anjuta_dirs.c anjuta_dirs.h anjuta_info.c anjuta_info.h appwiz_page1.c appwiz_page2.c appwiz_page3.c appwizard.c appwizard.h appwizard_cbs.c appwizard_cbs.h appwizard_gui.c attach_process.c attach_process.h attach_process_cbs.c attach_process_cbs.h attach_process_gui.c breakpoints.c breakpoints.h breakpoints_cbs.c breakpoints_cbs.h breakpoints_gui.c build_file.c build_file.h build_project.c build_project.h clean_project.c clean_project.h commands.c commands.h compile.c compile.h compiler_options.c compiler_options.h compiler_options_cbs.c compiler_options_cbs.h compiler_options_gui.c configurer.c configurer.h controls.c controls.h debugger.c debugger.h executer.c executer.h fileselection.c fileselection.h find_in_files.c find_in_files.h find_in_files_cbs.c find_in_files_cbs.h find_in_files_gui.c find_replace.c find_replace.h find_text.c find_text.h global.h gnome_project.c gnome_project.h goto_line.c goto_line.h help.c help.h launcher.c launcher.h lexer.h main.c main_menubar.c main_menubar.h main_menubar_def.h mainmenu_callbacks.c mainmenu_callbacks.h messagebox.c messagebox.h messages.c messages.h pixmaps.h preferences.c preferences.h preferences_gui.c project_dbase.c project_dbase.h project_config.c project_config.h project_dbase_gui.c properties.cxx properties.h registers.c registers.h registers_cbs.c registers_cbs.h registers_gui.c sharedlib.c sharedlib.h sharedlib_cbs.c sharedlib_cbs.h sharedlib_gui.c signals.c signals.h signals_cbs.c signals_cbs.h signals_gui.c splash.c splash.h src_paths.c src_paths.h src_paths_cbs.c src_paths_cbs.h src_paths_gui.c stack_trace.c stack_trace.h stack_trace_cbs.c stack_trace_cbs.h stack_trace_gui.c syntax.h tags_manager.c tags_manager.h text_editor.c text_editor.h text_editor_cbs.c text_editor_cbs.h text_editor_gui.c text_editor_gui.h text_editor_menu.c text_editor_menu.h toolbar.c toolbar.h toolbar_callbacks.c toolbar_callbacks.h utilities.c utilities.h watch.c watch.h watch_cbs.c watch_cbs.h watch_gui.c about.c appwiz_page4.c source.c anjuta.c anjuta_gui.c source.h glade_iface.c glade_iface.h compatibility_0.c compatibility_0.h defaults.c defaults.h about.h resources.c resources.h notebook.c notebook.h
+-SCILEXERS = ../scintilla/StyleContext.o ../scintilla/LexCPP.o ../scintilla/LexConf.o ../scintilla/LexHTML.o ../scintilla/LexLua.o ../scintilla/LexOthers.o ../scintilla/LexPerl.o ../scintilla/LexPython.o ../scintilla/LexSQL.o ../scintilla/LexVB.o ../scintilla/LexPascal.o ../scintilla/LexAVE.o ../scintilla/LexCrontab.o ../scintilla/LexEiffel.o ../scintilla/LexLisp.o ../scintilla/LexRuby.o ../scintilla/LexBullant.o ../scintilla/LexAda.o
++SCILEXERS = -lscintilla_lexers
--anjuta_LDADD = $(INTLLIBS) $(GNOME_LIBDIR) $(GNOMEUI_LIBS) -L../scintilla -L../widgets -L../ccview ../scintilla/LexCPP.o ../scintilla/LexConf.o ../scintilla/LexHTML.o ../scintilla/LexLua.o ../scintilla/LexOthers.o ../scintilla/LexPerl.o ../scintilla/LexPython.o ../scintilla/LexSQL.o ../scintilla/LexVB.o ../scintilla/LexPascal.o ../scintilla/LexAVE.o -lwidgets -lccview -lxml -lscintilla
-+anjuta_LDADD = $(INTLLIBS) $(GNOME_LIBDIR) $(GNOMEUI_LIBS) -L../widgets -L../ccview -lwidgets -lccview -lxml -lscintilla
- mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
- CONFIG_HEADER = ../config.h
-@@ -168,10 +168,7 @@
- watch_cbs.o watch_gui.o about.o appwiz_page4.o source.o anjuta.o \
- anjuta_gui.o glade_iface.o compatibility_0.o defaults.o resources.o \
- notebook.o
--anjuta_DEPENDENCIES = ../scintilla/LexCPP.o ../scintilla/LexConf.o \
--../scintilla/LexHTML.o ../scintilla/LexLua.o ../scintilla/LexOthers.o \
--../scintilla/LexPerl.o ../scintilla/LexPython.o ../scintilla/LexSQL.o \
--../scintilla/LexVB.o ../scintilla/LexPascal.o ../scintilla/LexAVE.o
+ bin_PROGRAMS = anjuta
+@@ -198,14 +198,7 @@
+ defaults.$(OBJEXT) resources.$(OBJEXT) notebook.$(OBJEXT) \
+ CORBA-Server.$(OBJEXT) Gladen-common.$(OBJEXT) glades.$(OBJEXT) \
+ Prj-common.$(OBJEXT) Gladen-stubs.$(OBJEXT) session.$(OBJEXT)
+-anjuta_DEPENDENCIES = ../scintilla/StyleContext.o ../scintilla/LexCPP.o \
+-../scintilla/LexConf.o ../scintilla/LexHTML.o ../scintilla/LexLua.o \
+-../scintilla/LexOthers.o ../scintilla/LexPerl.o \
+-../scintilla/LexPython.o ../scintilla/LexSQL.o ../scintilla/LexVB.o \
+-../scintilla/LexPascal.o ../scintilla/LexAVE.o \
+-../scintilla/LexCrontab.o ../scintilla/LexEiffel.o \
+-../scintilla/LexLisp.o ../scintilla/LexRuby.o ../scintilla/LexBullant.o \
+-../scintilla/LexAda.o
+anjuta_DEPENDENCIES =
anjuta_LDFLAGS =
CXXFLAGS = @CXXFLAGS@
CXXCOMPILE = $(CXX) $(DEFS) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CXXFLAGS) $(CXXFLAGS)
-@@ -297,14 +294,7 @@
- fi; \
- done
- about.o: about.c ../config.h utilities.h resources.h about.h
--aneditor.o: aneditor.cxx ../config.h ../scintilla/include/Platform.h \
-- ../scintilla/include/PropSet.h ../scintilla/include/SString.h \
-- ../scintilla/include/Accessor.h \
-- ../scintilla/include/WindowAccessor.h \
-- ../scintilla/include/KeyWords.h \
-- ../scintilla/include/Scintilla.h \
-- ../scintilla/include/ScintillaWidget.h \
-- ../scintilla/include/SciLexer.h lexer.h properties.h aneditor.h
-+aneditor.o: aneditor.cxx ../config.h lexer.h properties.h aneditor.h
- anjuta_cbs.o: anjuta_cbs.c ../config.h text_editor.h global.h \
- text_editor_menu.h preferences.h properties.h aneditor.h \
- anjuta.h toolbar.h messagebox.h compiler_options.h src_paths.h \
-@@ -333,9 +323,7 @@
- anjuta_dirs.h executer.h configurer.h utilities.h \
- main_menubar.h help.h fileselection.h resources.h launcher.h \
- debugger.h watch.h registers.h stack_trace.h signals.h \
-- sharedlib.h attach_process.h controls.h anjuta_info.h \
-- ../scintilla/include/Scintilla.h \
-- ../scintilla/include/ScintillaWidget.h
-+ sharedlib.h attach_process.h controls.h anjuta_info.h
- appwizard_cbs.o: appwizard_cbs.c ../config.h anjuta.h toolbar.h \
- text_editor.h global.h text_editor_menu.h preferences.h \
- properties.h aneditor.h messagebox.h compiler_options.h \
-@@ -501,8 +489,7 @@
- find_text.h find_in_files.h messages.h project_dbase.h \
- tags_manager.h project_config.h commands.h anjuta_dirs.h \
- executer.h configurer.h utilities.h main_menubar.h help.h \
-- controls.h ../scintilla/include/Scintilla.h \
-- ../scintilla/include/ScintillaWidget.h
-+ controls.h
- debugger.o: debugger.c ../config.h anjuta.h toolbar.h text_editor.h \
- global.h text_editor_menu.h preferences.h properties.h \
- aneditor.h messagebox.h compiler_options.h src_paths.h \
-@@ -557,9 +544,7 @@
- src_paths.h find_replace.h find_text.h find_in_files.h \
- messages.h project_dbase.h tags_manager.h project_config.h \
- commands.h breakpoints.h anjuta_dirs.h executer.h configurer.h \
-- utilities.h main_menubar.h help.h resources.h \
-- ../scintilla/include/Scintilla.h \
-- ../scintilla/include/ScintillaWidget.h
-+ utilities.h main_menubar.h help.h resources.h
- find_text.o: find_text.c ../config.h anjuta.h toolbar.h text_editor.h \
- global.h text_editor_menu.h preferences.h properties.h \
- aneditor.h messagebox.h compiler_options.h src_paths.h \
-@@ -622,8 +607,7 @@
- compile.h launcher.h appwizard.h debugger.h watch.h registers.h \
- stack_trace.h signals.h sharedlib.h attach_process.h \
- breakpoints_cbs.h goto_line.h resources.h controls.h \
-- signals_cbs.h watch_cbs.h ../scintilla/include/Scintilla.h \
-- ../scintilla/include/ScintillaWidget.h
-+ signals_cbs.h watch_cbs.h
- main.o: main.c ../config.h splash.h anjuta.h toolbar.h text_editor.h \
- global.h text_editor_menu.h preferences.h properties.h \
- aneditor.h messagebox.h compiler_options.h src_paths.h \
-@@ -685,8 +669,7 @@
- ../pixmaps/file_cpp.xpm ../pixmaps/file_h.xpm \
- ../pixmaps/file_pix.xpm ../pixmaps/file_icon.xpm \
- ../pixmaps/file_html.xpm ../pixmaps/file_i18n.xpm
--properties.o: properties.cxx ../scintilla/include/PropSet.h \
-- ../scintilla/include/SString.h properties.h
-+properties.o: properties.cxx
- registers_cbs.o: registers_cbs.c ../config.h registers.h properties.h \
- registers_cbs.h debugger.h global.h breakpoints.h text_editor.h \
- text_editor_menu.h preferences.h aneditor.h watch.h \
-@@ -791,8 +774,7 @@
- messages.h project_dbase.h tags_manager.h project_config.h \
- commands.h breakpoints.h anjuta_dirs.h executer.h configurer.h \
- utilities.h main_menubar.h help.h controls.h text_editor_cbs.h \
-- text_editor_gui.h mainmenu_callbacks.h resources.h \
-- ../scintilla/include/Scintilla.h
-+ text_editor_gui.h mainmenu_callbacks.h resources.h
- text_editor_gui.o: text_editor_gui.c ../config.h anjuta.h toolbar.h \
- text_editor.h global.h text_editor_menu.h preferences.h \
- properties.h aneditor.h messagebox.h compiler_options.h \
-@@ -800,9 +782,7 @@
- messages.h project_dbase.h tags_manager.h project_config.h \
- commands.h breakpoints.h anjuta_dirs.h executer.h configurer.h \
- utilities.h main_menubar.h help.h text_editor_cbs.h \
-- text_editor_gui.h mainmenu_callbacks.h pixmaps.h resources.h \
-- ../scintilla/include/Scintilla.h \
-- ../scintilla/include/ScintillaWidget.h
-+ text_editor_gui.h mainmenu_callbacks.h pixmaps.h resources.h
- text_editor_menu.o: text_editor_menu.c ../config.h resources.h \
- text_editor_menu.h anjuta.h toolbar.h text_editor.h global.h \
- preferences.h properties.h aneditor.h messagebox.h \
-@@ -820,10 +800,7 @@
- messages.h project_dbase.h tags_manager.h project_config.h \
- commands.h breakpoints.h anjuta_dirs.h executer.h configurer.h \
- utilities.h main_menubar.h help.h text_editor_gui.h \
-- text_editor_cbs.h syntax.h launcher.h \
-- ../scintilla/include/Scintilla.h \
-- ../scintilla/include/SciLexer.h \
-- ../scintilla/include/ScintillaWidget.h lexer.h controls.h
-+ text_editor_cbs.h syntax.h launcher.h lexer.h controls.h
- toolbar_callbacks.o: toolbar_callbacks.c ../config.h anjuta.h toolbar.h \
- text_editor.h global.h text_editor_menu.h preferences.h \
- properties.h aneditor.h messagebox.h compiler_options.h \
diff --git a/devel/anjuta-devel/files/patch-src::anjuta.c b/devel/anjuta-devel/files/patch-src::anjuta.c
new file mode 100644
index 000000000000..39809a1af638
--- /dev/null
+++ b/devel/anjuta-devel/files/patch-src::anjuta.c
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- src/anjuta.c 2002/01/04 13:31:53 1.1
++++ src/anjuta.c 2002/01/04 13:34:07
+@@ -148,7 +148,7 @@
+ app->fileselection = create_fileselection_gui (&fsd1);
+
+ /* Set to the current dir */
+- fileselection_set_dir (app->fileselection, (gchar *)get_current_dir_name());
++ fileselection_set_dir (app->fileselection, (gchar *)g_get_current_dir ());
+
+ app->save_as_fileselection = create_fileselection_gui (&fsd2);
+ app->save_as_build_msg_sel = create_fileselection_gui (&fsd3);