aboutsummaryrefslogtreecommitdiff
path: root/devel/anjuta/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/anjuta/Makefile')
-rw-r--r--devel/anjuta/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/devel/anjuta/Makefile b/devel/anjuta/Makefile
index 51b7839f846b..aa9d01501f42 100644
--- a/devel/anjuta/Makefile
+++ b/devel/anjuta/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= anjuta
-PORTVERSION= 1.0.1
-PORTREVISION= 1
+PORTVERSION= 1.0.2
CATEGORIES= devel gnome
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= anjuta
@@ -15,7 +14,8 @@ MASTER_SITE_SUBDIR= anjuta
MAINTAINER= gnome@FreeBSD.org
COMMENT= Integrated Development Environment for C and C++
-LIB_DEPENDS= scintilla.1:${PORTSDIR}/x11-toolkits/scintilla
+LIB_DEPENDS= scintilla.1:${PORTSDIR}/x11-toolkits/scintilla \
+ pcre.0:${PORTSDIR}/devel/pcre
USE_X_PREFIX= yes
USE_GMAKE= yes
@@ -29,5 +29,7 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
post-patch:
@${REINPLACE_CMD} -e 's#-lpthread#${PTHREAD_LIBS}#g ; \
s#DATADIRNAME=lib#DATADIRNAME=share#g' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|%%X11BASE%%|${X11BASE}|g' \
+ ${WRKSRC}/src/Makefile.in
.include <bsd.port.mk>