aboutsummaryrefslogtreecommitdiff
path: root/devel/arduino/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/arduino/Makefile')
-rw-r--r--devel/arduino/Makefile41
1 files changed, 11 insertions, 30 deletions
diff --git a/devel/arduino/Makefile b/devel/arduino/Makefile
index 3afe5b446034..ac84be03842f 100644
--- a/devel/arduino/Makefile
+++ b/devel/arduino/Makefile
@@ -4,8 +4,7 @@
# $FreeBSD$
PORTNAME= arduino
-PORTVERSION= 1.0
-PORTREVISION= 2
+PORTVERSION= 1.0.1
PORTEPOCH= 1
CATEGORIES= devel java lang
MASTER_SITES= GOOGLE_CODE
@@ -34,55 +33,37 @@ DESKTOP_ENTRIES= "Arduino" "Arduino IDE" \
${PREFIX}/${PORTNAME}/reference/img/logo.png \
"arduino" "Development;IDE;" "false"
-.if !defined(NOPORTDOCS)
-OPTIONS+= REFDOCS "Install the reference documents" on
-.endif
-.if !defined(NOPORTEXAMPLES)
-OPTIONS+= EXAMPLES "Install the example code" on
-.endif
+OPTIONS_DEFINE+= DOCS EXAMPLES
+DOCS_DESC= Install the reference documents
.include <bsd.port.options.mk>
-.if defined(WITHOUT_REFDOCS) || defined(NOPORTDOCS)
-WITHOUT_REFDOCS= true
-.undef WITH_REFDOCS
+.if empty(PORT_OPTIONS:MDOCS)
PLIST_SUB+= REFDOCS="@comment "
.else
PLIST_SUB+= REFDOCS=""
.endif
-.if defined(WITHOUT_EXAMPLES) || defined(NOPORTEXAMPLES)
-WITHOUT_EXAMPLES= true
-.undef WITH_EXAMPLES
+.if empty(PORT_OPTIONS:MEXAMPLES)
PLIST_SUB+= EXAMPLES="@comment "
.else
PLIST_SUB+= EXAMPLES=""
.endif
-post-extract:
- @${RM} ${WRKSRC}/hardware/tools/avrdude
- @${RM} ${WRKSRC}/hardware/tools/avrdude64
- @${RM} ${WRKSRC}/hardware/tools/avrdude.conf
- @${RM} ${WRKSRC}/lib/librxtxSerial64.so
- @${MKDIR} ${WRKSRC}/hardware/tools/avr
+post-patch:
+ @${RM} ${WRKSRC}/hardware/arduino/bootloaders/atmega8/ATmegaBOOT.c.orig
+ @${RM} -rf ${WRKSRC}/hardware/tools/
+ @${MKDIR} ${WRKSRC}/hardware/tools/avr/
@${LN} -s ${PREFIX}/bin ${WRKSRC}/hardware/tools/avr/bin
@${LN} -s ${PREFIX}/etc ${WRKSRC}/hardware/tools/avr/etc
@${RM} ${WRKSRC}/lib/RXTXcomm.jar
@${LN} -s ${JAVA_HOME}/lib/ext/RXTXcomm.jar ${WRKSRC}/lib/RXTXcomm.jar
- @${RM} ${WRKSRC}/lib/librxtxSerial.so
- @${LN} -s ${JAVA_HOME}/lib/${ARCH}/librxtxSerial.so ${WRKSRC}/lib/
-
- @${REINPLACE_CMD} -e 's|readlink -f|realpath|g' ${WRKSRC}/arduino
-
-post-patch:
- @${RM} -f ${WRKSRC}/hardware/arduino/bootloaders/atmega8/*.orig ${WRKSRC}/hardware/arduino/cores/arduino/Print.cpp.orig
-
-.if defined(WITHOUT_REFDOCS)
+.if empty(PORT_OPTIONS:MDOCS)
@${RM} -rf ${WRKSRC}/reference
.endif
-.if defined(WITHOUT_EXAMPLES)
+.if empty(PORT_OPTIONS:MEXAMPLES)
@${RM} -rf ${WRKSRC}/examples
@${RM} -rf ${WRKSRC}/libraries/*/examples
.endif