aboutsummaryrefslogtreecommitdiff
path: root/devel/asmutils/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/asmutils/Makefile')
-rw-r--r--devel/asmutils/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/devel/asmutils/Makefile b/devel/asmutils/Makefile
index f84a263fb921..e8a974e8cec2 100644
--- a/devel/asmutils/Makefile
+++ b/devel/asmutils/Makefile
@@ -21,6 +21,7 @@ ONLY_FOR_ARCHS= i386
BUILD_DEPENDS= nasm:${PORTSDIR}/devel/nasm
USE_GMAKE= yes
+MAKE_ARGS= OS=${OPSYS:U} KERNEL=${OSREL:S/.//g}
# This will play merry hell with portlint(1)
BINS= bonus/asmutils basename cal cat chmod chown chroot cmp cp \
@@ -45,7 +46,6 @@ PLIST_DIRS= bin/asmutils lib/asmutils
PORTDOCS= *
post-patch:
- @${REINPLACE_CMD} -e 's,%%KERNEL%%,${OSREL:S/.//g},g' ${WRKSRC}/MCONFIG
@${REINPLACE_CMD} -e 's,^static ,,' ${WRKSRC}/lib/libm.c
# Stripping binaries will break installation