aboutsummaryrefslogtreecommitdiff
path: root/devel/astyle/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/astyle/Makefile')
-rw-r--r--devel/astyle/Makefile21
1 files changed, 13 insertions, 8 deletions
diff --git a/devel/astyle/Makefile b/devel/astyle/Makefile
index de06cfc10efa..0f2ae5ca0d17 100644
--- a/devel/astyle/Makefile
+++ b/devel/astyle/Makefile
@@ -1,25 +1,30 @@
# New ports collection makefile for: astyle
-# Version required: 1.6.0
+# Version required: 1.10.1
# Date created: 31 Jan 1999
# Whom: Don Croyle <croyle@gelemna.ft-wayne.in.us>
#
-# $Id$
+# $Id: Makefile,v 1.1.1.1 1999/04/03 01:26:17 steve Exp $
#
-DISTNAME= astyle_1.6.0
-PKGNAME= astyle-1.6.0
+DISTNAME= astyle_1.10.1_src
+PKGNAME= astyle-1.10.1
CATEGORIES= devel textproc
-MASTER_SITES= http://www.bigfoot.com/~davidsont/astyle/stable/src/ \
+MASTER_SITES= http://gene.md.huji.ac.il/~tald/astyle/stable/src/ \
http://www.infonex.com/~dacroyle/freebsd/
EXTRACT_SUFX= .tgz
MAINTAINER= croyle@gelemna.ft-wayne.in.us
-BUILD_DEPENDS= eg++:${PORTSDIR}/lang/egcs
-
-WRKSRC= ${WRKDIR}/astyle-src
+WRKSRC= ${WRKDIR}/astyle_1.10.1
ALL_TARGET= astyle
+post-extract:
+ perl -pi -e 's/\r//' ${WRKSRC}/*
+
+post-patch:
+ ${MV} ${WRKSRC}/Makefile ${WRKSRC}/Makefile.orig
+ ${CP} -p ${FILESDIR}/Makefile ${WRKSRC}/
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/astyle ${PREFIX}/bin/