aboutsummaryrefslogtreecommitdiff
path: root/devel/autoconf/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/autoconf/Makefile')
-rw-r--r--devel/autoconf/Makefile18
1 files changed, 8 insertions, 10 deletions
diff --git a/devel/autoconf/Makefile b/devel/autoconf/Makefile
index b4fdab409601..d81fbf822f65 100644
--- a/devel/autoconf/Makefile
+++ b/devel/autoconf/Makefile
@@ -6,30 +6,30 @@
#
PORTNAME= autoconf
-PORTVERSION= 2.68
+PORTVERSION= 2.69
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= autoconf
DISTNAME= autoconf-${PORTVERSION}
MAINTAINER= autotools@FreeBSD.org
-COMMENT= Automatically configure source code on many Un*x platforms (2.68)
+COMMENT= Automatically configure source code on many Un*x platforms
BUILD_DEPENDS= gm4:${PORTSDIR}/devel/m4 \
help2man:${PORTSDIR}/misc/help2man
RUN_DEPENDS= gm4:${PORTSDIR}/devel/m4 \
autoconf-wrapper:${PORTSDIR}/devel/autoconf-wrapper
-BUILD_VERSION= 2.68
+BUILD_VERSION= 2.69
PLIST_SUB= BUILD_VERSION=${BUILD_VERSION}
-LATEST_LINK= autoconf268
-USE_BZIP2= yes
+USE_XZ= yes
USE_GMAKE= yes
USE_PERL5= yes
-INFO= autoconf-${BUILD_VERSION}
+INFO= autoconf
GNU_CONFIGURE= yes
-CONFIGURE_ENV+= CONFIG_SHELL=${SH} M4=${LOCALBASE}/bin/gm4 AWK=${AWK}
+CONFIGURE_ENV+= CONFIG_SHELL=${SH} M4=${LOCALBASE}/bin/gm4 AWK=${AWK} \
+ ac_cv_prog_TEST_EMACS=no
CONFIGURE_ARGS= --program-suffix=-${BUILD_VERSION} --without-lispdir
GENERIC_TOOLS= config.guess config.sub elisp-comp install-sh mdate-sh missing
@@ -45,9 +45,7 @@ post-patch:
${REINPLACE_CMD} -E 's,([^-]auto)(conf|make|reconf|update|header|scan),\1\2-${BUILD_VERSION},g ; \
s,(config\.guess|config\.sub|ifnames),\1-${BUILD_VERSION},g' $$file ; \
done)
- @(cd ${WRKSRC}/doc && \
- ${RM} -f *.info && \
- ${MV} autoconf.texi autoconf-${BUILD_VERSION}.texi)
+ @(cd ${WRKSRC}/doc && ${RM} -f *.info)
@${FIND} ${WRKSRC} -name Makefile.in | ${XARGS} ${REINPLACE_CMD} -e \
's|@PACKAGE@$$|@PACKAGE@-@VERSION@|'