aboutsummaryrefslogtreecommitdiff
path: root/devel/autoconf
diff options
context:
space:
mode:
Diffstat (limited to 'devel/autoconf')
-rw-r--r--devel/autoconf/Makefile18
-rw-r--r--devel/autoconf/distinfo4
-rw-r--r--devel/autoconf/files/patch-autoconf.texi24
-rw-r--r--devel/autoconf/files/patch-doc-Makefile.in17
-rw-r--r--devel/autoconf/pkg-plist3
5 files changed, 22 insertions, 44 deletions
diff --git a/devel/autoconf/Makefile b/devel/autoconf/Makefile
index b4fdab409601..d81fbf822f65 100644
--- a/devel/autoconf/Makefile
+++ b/devel/autoconf/Makefile
@@ -6,30 +6,30 @@
#
PORTNAME= autoconf
-PORTVERSION= 2.68
+PORTVERSION= 2.69
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= autoconf
DISTNAME= autoconf-${PORTVERSION}
MAINTAINER= autotools@FreeBSD.org
-COMMENT= Automatically configure source code on many Un*x platforms (2.68)
+COMMENT= Automatically configure source code on many Un*x platforms
BUILD_DEPENDS= gm4:${PORTSDIR}/devel/m4 \
help2man:${PORTSDIR}/misc/help2man
RUN_DEPENDS= gm4:${PORTSDIR}/devel/m4 \
autoconf-wrapper:${PORTSDIR}/devel/autoconf-wrapper
-BUILD_VERSION= 2.68
+BUILD_VERSION= 2.69
PLIST_SUB= BUILD_VERSION=${BUILD_VERSION}
-LATEST_LINK= autoconf268
-USE_BZIP2= yes
+USE_XZ= yes
USE_GMAKE= yes
USE_PERL5= yes
-INFO= autoconf-${BUILD_VERSION}
+INFO= autoconf
GNU_CONFIGURE= yes
-CONFIGURE_ENV+= CONFIG_SHELL=${SH} M4=${LOCALBASE}/bin/gm4 AWK=${AWK}
+CONFIGURE_ENV+= CONFIG_SHELL=${SH} M4=${LOCALBASE}/bin/gm4 AWK=${AWK} \
+ ac_cv_prog_TEST_EMACS=no
CONFIGURE_ARGS= --program-suffix=-${BUILD_VERSION} --without-lispdir
GENERIC_TOOLS= config.guess config.sub elisp-comp install-sh mdate-sh missing
@@ -45,9 +45,7 @@ post-patch:
${REINPLACE_CMD} -E 's,([^-]auto)(conf|make|reconf|update|header|scan),\1\2-${BUILD_VERSION},g ; \
s,(config\.guess|config\.sub|ifnames),\1-${BUILD_VERSION},g' $$file ; \
done)
- @(cd ${WRKSRC}/doc && \
- ${RM} -f *.info && \
- ${MV} autoconf.texi autoconf-${BUILD_VERSION}.texi)
+ @(cd ${WRKSRC}/doc && ${RM} -f *.info)
@${FIND} ${WRKSRC} -name Makefile.in | ${XARGS} ${REINPLACE_CMD} -e \
's|@PACKAGE@$$|@PACKAGE@-@VERSION@|'
diff --git a/devel/autoconf/distinfo b/devel/autoconf/distinfo
index 67a10a20920a..3359cad88dd4 100644
--- a/devel/autoconf/distinfo
+++ b/devel/autoconf/distinfo
@@ -1,2 +1,2 @@
-SHA256 (autoconf-2.68.tar.bz2) = c491fb273fd6d4ca925e26ceed3d177920233c76d542b150ff35e571454332c8
-SIZE (autoconf-2.68.tar.bz2) = 1381988
+SHA256 (autoconf-2.69.tar.xz) = 64ebcec9f8ac5b2487125a86a7760d2591ac9e1d3dbd59489633f9de62a57684
+SIZE (autoconf-2.69.tar.xz) = 1214744
diff --git a/devel/autoconf/files/patch-autoconf.texi b/devel/autoconf/files/patch-autoconf.texi
index d37b7fbbedab..a7e1f2637b53 100644
--- a/devel/autoconf/files/patch-autoconf.texi
+++ b/devel/autoconf/files/patch-autoconf.texi
@@ -1,21 +1,12 @@
---- doc/autoconf.texi.orig 2008-04-05 11:43:30.000000000 -0700
-+++ doc/autoconf.texi 2008-05-16 18:27:31.000000000 -0700
-@@ -3,5 +3,5 @@
- @comment %**start of header
--@setfilename autoconf.info
-+@setfilename autoconf-2.68.info
- @include version.texi
--@settitle Autoconf
-+@settitle Autoconf-2.68
- @setchapternewpage odd
-@@ -205,25 +205,5 @@
+--- doc/autoconf.texi.orig 2012-04-24 19:14:19.000000000 -0700
++++ doc/autoconf.texi 2012-04-26 10:52:26.000000000 -0700
+@@ -219,3 +219,3 @@
-@dircategory Software development
+@dircategory Programming & development tools
@direntry
--* Autoconf: (autoconf). Create source code configuration scripts.
--@end direntry
--
+@@ -224,22 +224,2 @@
+
-@dircategory Individual utilities
-@direntry
-* autoscan: (autoconf)autoscan Invocation.
@@ -34,5 +25,6 @@
- Automatic update of @file{configure.ac}
-* config.status: (autoconf)config.status Invocation. Recreating configurations.
-* testsuite: (autoconf)testsuite Invocation. Running an Autotest test suite.
-+* Autoconf-2.68: (autoconf-2.68). Create source code configuration scripts.
- @end direntry
+-@end direntry
+-
+ @titlepage
diff --git a/devel/autoconf/files/patch-doc-Makefile.in b/devel/autoconf/files/patch-doc-Makefile.in
index ba8a63bbcb84..1cba4ecf6f6f 100644
--- a/devel/autoconf/files/patch-doc-Makefile.in
+++ b/devel/autoconf/files/patch-doc-Makefile.in
@@ -3,23 +3,10 @@
@@ -44,3 +44,3 @@
DIST_SOURCES =
-INFO_DEPS = $(srcdir)/autoconf.info $(srcdir)/standards.info
-+INFO_DEPS = $(srcdir)/autoconf-2.68.info
++INFO_DEPS = $(srcdir)/autoconf.info
TEXINFO_TEX = $(top_srcdir)/build-aux/texinfo.tex
@@ -51,3 +51,3 @@
HTMLS = autoconf.html standards.html
-TEXINFOS = autoconf.texi standards.texi
-+TEXINFOS = autoconf-2.68.texi
++TEXINFOS = autoconf.texi
TEXI2PDF = $(TEXI2DVI) --pdf --batch
-@@ -241,3 +241,3 @@
- fi
--$(srcdir)/autoconf.info: autoconf.texi $(srcdir)/version.texi $(autoconf_TEXINFOS)
-+$(srcdir)/autoconf-2.68.info: autoconf-2.68.texi $(srcdir)/version.texi $(autoconf_TEXINFOS)
- autoconf.dvi: autoconf.texi $(srcdir)/version.texi $(autoconf_TEXINFOS)
-@@ -246,5 +246,5 @@
- $(srcdir)/version.texi: $(srcdir)/stamp-vti
--$(srcdir)/stamp-vti: autoconf.texi $(top_srcdir)/configure
-+$(srcdir)/stamp-vti: autoconf-2.68.texi $(top_srcdir)/configure
- @(dir=.; test -f ./autoconf.texi || dir=$(srcdir); \
-- set `$(SHELL) $(top_srcdir)/build-aux/mdate-sh $$dir/autoconf.texi`; \
-+ set `$(SHELL) $(top_srcdir)/build-aux/mdate-sh $$dir/autoconf-2.68.texi`; \
- echo "@set UPDATED $$1 $$2 $$3"; \
diff --git a/devel/autoconf/pkg-plist b/devel/autoconf/pkg-plist
index 69fac8d76272..2b983e668209 100644
--- a/devel/autoconf/pkg-plist
+++ b/devel/autoconf/pkg-plist
@@ -11,8 +11,8 @@ share/autoconf-%%BUILD_VERSION%%/Autom4te/Channels.pm
share/autoconf-%%BUILD_VERSION%%/Autom4te/Configure_ac.pm
share/autoconf-%%BUILD_VERSION%%/Autom4te/FileUtils.pm
share/autoconf-%%BUILD_VERSION%%/Autom4te/General.pm
+share/autoconf-%%BUILD_VERSION%%/Autom4te/Getopt.pm
share/autoconf-%%BUILD_VERSION%%/Autom4te/Request.pm
-share/autoconf-%%BUILD_VERSION%%/Autom4te/Struct.pm
share/autoconf-%%BUILD_VERSION%%/Autom4te/XFile.pm
share/autoconf-%%BUILD_VERSION%%/INSTALL
share/autoconf-%%BUILD_VERSION%%/autoconf/autoconf.m4
@@ -26,6 +26,7 @@ share/autoconf-%%BUILD_VERSION%%/autoconf/erlang.m4
share/autoconf-%%BUILD_VERSION%%/autoconf/fortran.m4
share/autoconf-%%BUILD_VERSION%%/autoconf/functions.m4
share/autoconf-%%BUILD_VERSION%%/autoconf/general.m4
+share/autoconf-%%BUILD_VERSION%%/autoconf/go.m4
share/autoconf-%%BUILD_VERSION%%/autoconf/headers.m4
share/autoconf-%%BUILD_VERSION%%/autoconf/lang.m4
share/autoconf-%%BUILD_VERSION%%/autoconf/libs.m4