aboutsummaryrefslogtreecommitdiff
path: root/devel/automake16/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/automake16/Makefile')
-rw-r--r--devel/automake16/Makefile41
1 files changed, 41 insertions, 0 deletions
diff --git a/devel/automake16/Makefile b/devel/automake16/Makefile
new file mode 100644
index 000000000000..07b1c5877e18
--- /dev/null
+++ b/devel/automake16/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: automake
+# Date created: 14th April 2007
+# Whom: Ade Lovett <ade@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= automake
+PORTVERSION= 1.6.3
+CATEGORIES= devel
+MASTER_SITES= ${MASTER_SITE_GNU}
+MASTER_SITE_SUBDIR= automake
+
+MAINTAINER= ade@FreeBSD.org
+COMMENT= GNU Standards-compliant Makefile generator (1.6)
+
+RUN_DEPENDS= ${AUTOCONF_DEPENDS} \
+ automake-wrapper:${PORTSDIR}/devel/automake-wrapper
+
+USE_AUTOTOOLS= autoconf:261:env
+BUILD_VERSION= 1.6
+PLIST_SUB= BUILD_VERSION=${BUILD_VERSION}
+LATEST_LINK= automake16
+USE_PERL5= yes
+USE_BZIP2= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= MAKEINFO="makeinfo --no-split"
+CONFIGURE_ARGS= --program-suffix=-${BUILD_VERSION}
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+INFO= automake-${BUILD_VERSION}
+
+post-patch:
+ @${RM} ${WRKSRC}/*.info
+ @${MV} ${WRKSRC}/automake.texi ${WRKSRC}/automake-${BUILD_VERSION}.texi
+
+pre-su-install:
+ @${RM} -fr ${PREFIX}/share/automake-${BUILD_VERSION}
+ @${MKDIR} ${PREFIX}/share/automake-${BUILD_VERSION}
+ @${MKDIR} ${PREFIX}/share/aclocal-${BUILD_VERSION}
+
+.include <bsd.port.mk>