aboutsummaryrefslogtreecommitdiff
path: root/devel/bisoncpp/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/bisoncpp/Makefile')
-rw-r--r--devel/bisoncpp/Makefile37
1 files changed, 25 insertions, 12 deletions
diff --git a/devel/bisoncpp/Makefile b/devel/bisoncpp/Makefile
index c0c65703976a..2b4c72c75a56 100644
--- a/devel/bisoncpp/Makefile
+++ b/devel/bisoncpp/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= bisoncpp
-PORTVERSION= 2.4.5
+PORTVERSION= 2.4.8
CATEGORIES= devel
MASTER_SITES= SF/${PORTNAME}/bisonc%2B%2B/${PORTVERSION}
DISTNAME= bisonc++_${PORTVERSION}
@@ -16,11 +16,14 @@ MAINTAINER= pgj@FreeBSD.org
COMMENT= LALR(1) parser generator that generates C++ classes
BUILD_DEPENDS= icmake:${PORTSDIR}/devel/icmake \
- yodl>=2.0:${PORTSDIR}/textproc/yodl
-LIB_DEPENDS= bobcat.2:${PORTSDIR}/devel/libbobcat
+ yodl>=2.0:${PORTSDIR}/textproc/yodl \
+ libbobcat>=2.05.00:${PORTSDIR}/devel/libbobcat \
+ g++45:${PORTSDIR}/lang/gcc45
+.if !defined(NO_INSTALL_MANPAGES)
MANCOMPRESSED= yes
MAN1= bisonc++.1
+.endif
DOCSDIR= ${PREFIX}/share/doc/${PORTNAME}-${PORTVERSION}
PORTDOCS= *
@@ -33,29 +36,39 @@ post-patch:
@${REINPLACE_CMD} -e 's|"/usr"|"${PREFIX}"| ; \
s|"/share/bisonc++"|"/share/${PORTNAME}-${PORTVERSION}"| ; \
s|"/share/doc/bisonc++"|"/share/doc/${PORTNAME}-${PORTVERSION}"| ; \
- s|"/share/man/man1"|"/man/man1"|' \
+ s|"/share/man/man1"|"/man/man1"| ; \
+ s|"g++"|"g++45"|' \
${WRKSRC}/INSTALL.im
@${REINPLACE_CMD} -e 's|#!/usr/bin/icmake|#!${LOCALBASE}/bin/icmake|' \
- ${WRKSRC}/build
- @${REINPLACE_CMD} -e 's|#!/usr/bin/icmake|#!${LOCALBASE}/bin/icmake| ; \
- s|"-Wall -O3"|"-Wall ${CXXFLAGS} -I${LOCALBASE}/include"| ; \
+ ${WRKSRC}/build \
+ ${WRKSRC}/scanner/driver/build \
+ ${WRKSRC}/parser/driver/build
+ @${REINPLACE_CMD} -e 's|"-Wall -O3|"-Wall ${CXXFLAGS} -I${LOCALBASE}/include| ; \
s|""|"${LOCALBASE}/lib"|' \
${WRKSRC}/icmake/library
@${REINPLACE_CMD} -e 's|"cp -d |"cp -Pp | ; \
- s|"cp -r |"cp -R |' \
+ s|"cp -r |"cp -R | ; \
+ s|"-doc"|"/doc"|' \
${WRKSRC}/icmake/install
+ @${REINPLACE_CMD} -e 's|libpath|libpath, "-Wl,--allow-shlib-undefined"|' \
+ ${WRKSRC}/icmake/program
do-build:
- @cd ${WRKSRC} && ./build program strip && ./build man
+ @cd ${WRKSRC} && ./build program strip
+.if !defined(NO_INSTALL_MANPAGES)
+ @cd ${WRKSRC} && ./build man
+.endif
.if !defined(NOPORTDOCS)
@cd ${WRKSRC} && ./build manual
.endif
do-install:
+ cd ${WRKSRC} && ./build install program
+.if !defined(NO_INSTALL_MANPAGES)
+ cd ${WRKSRC} && ./build install man
+.endif
.if !defined(NOPORTDOCS)
- cd ${WRKSRC} && ./build install
-.else
- cd ${WRKSRC} && ./build installprog
+ cd ${WRKSRC} && ./build install manual
.endif
.include <bsd.port.mk>