aboutsummaryrefslogtreecommitdiff
path: root/devel/boost-docs/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/boost-docs/Makefile')
-rw-r--r--devel/boost-docs/Makefile10
1 files changed, 3 insertions, 7 deletions
diff --git a/devel/boost-docs/Makefile b/devel/boost-docs/Makefile
index c675478dd1e6..b7de9bd34075 100644
--- a/devel/boost-docs/Makefile
+++ b/devel/boost-docs/Makefile
@@ -9,25 +9,21 @@ UNIQ= /usr/bin/uniq
NO_BUILD= yes
-NO_STAGE= yes
.include "${.CURDIR}/..//boost-all/common.mk"
do-install:
# Documentation & examples
- @${MKDIR} ${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
@cd ${WRKSRC} &&\
${FIND} . -name "*.htm" -o -name "*.html" -o -name "*.css"\
-o -name "*.jp*g" -o -name "*.png" -o -name "*.gif"\
- | ${PAX} -rw ${DOCSDIR}
+ | ${PAX} -rw ${STAGEDIR}${DOCSDIR}
@cd ${WRKSRC}/libs &&\
${FIND} . -name "example" -o -name "examples" -o -name "*example*.cpp"\
-o -name "*example*.c" -o -name "*example*.hpp" | ${UNIQ} |\
${GREP} -v "assign/test" | ${GREP} -v "iterator/test" | \
${GREP} -v "range/test" |\
- ${PAX} -rw ${DOCSDIR}/libs
- @${FIND} ${DOCSDIR} -type f -exec ${CHMOD} 0444 {} \;
- @${FIND} ${DOCSDIR} -type d -exec ${CHMOD} 0755 {} \;
-
+ ${PAX} -rw ${STAGEDIR}${DOCSDIR}/libs
.include <bsd.port.mk>