aboutsummaryrefslogtreecommitdiff
path: root/devel/boost-libs/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/boost-libs/Makefile')
-rw-r--r--devel/boost-libs/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/devel/boost-libs/Makefile b/devel/boost-libs/Makefile
index 611c8f13417c..cdf73d9b654d 100644
--- a/devel/boost-libs/Makefile
+++ b/devel/boost-libs/Makefile
@@ -16,6 +16,14 @@ ICU_DESC= Boost.Regex with ICU unicode support
.include "${.CURDIR}/../boost-all/compiled.mk"
BJAM_ARGS+= --without-python
+.if defined(X_BUILD_FOR)
+BJAM_ARGS+= --without-context --without-coroutine \
+ --without-locale --without-log
+PLIST_SUB= COROUTINE="@comment " CONTEXT="@comment " \
+ LOCALE="@comment " LOG="@comment "
+.else
+PLIST_SUB= COROUTINE="" CONTEXT="" LOCALE="" LOG=""
+.endif
.if ${PORT_OPTIONS:MICU}
LIB_DEPENDS+= libicuuc.so:${PORTSDIR}/devel/icu