aboutsummaryrefslogtreecommitdiff
path: root/devel/boost-python-libs
diff options
context:
space:
mode:
Diffstat (limited to 'devel/boost-python-libs')
-rw-r--r--devel/boost-python-libs/Makefile109
-rw-r--r--devel/boost-python-libs/distinfo3
-rw-r--r--devel/boost-python-libs/files/patch-tools_build_v2_tools_common.jam17
-rw-r--r--devel/boost-python-libs/files/patch-tools_build_v2_tools_gcc.jam54
-rw-r--r--devel/boost-python-libs/files/patch-tools_build_v2_tools_python.jam11
-rw-r--r--devel/boost-python-libs/files/patch-tools_jam_src_build.jam11
-rw-r--r--devel/boost-python-libs/pkg-descr6
-rw-r--r--devel/boost-python-libs/pkg-plist287
8 files changed, 498 insertions, 0 deletions
diff --git a/devel/boost-python-libs/Makefile b/devel/boost-python-libs/Makefile
new file mode 100644
index 000000000000..4f13dd662271
--- /dev/null
+++ b/devel/boost-python-libs/Makefile
@@ -0,0 +1,109 @@
+# Ports collection makefile for: boost-python-libs
+# Date Created: 18 March 2009
+# Whom: Alexander Churanov <churanov.port.maintainer@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= boost-python-libs
+COMMENT= Framework for interfacing Python and C++
+
+USE_BZIP2= yes
+USE_PYTHON= 2.4+
+
+OPTIONS= VERBOSE_BUILD "Show compiler messages" off \
+ DEBUG "Build debugging symbols" off \
+ OPTIMIZED_CFLAGS "Enable -O3 optimization" off
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/devel/boost-all/common.mk"
+.include "${PORTSDIR}/devel/boost-all/sites.mk"
+.include "${PORTSDIR}/devel/boost-all/compiled.mk"
+
+MAKE_ENV+= PYTHON_ROOT="${LOCALBASE}"\
+ PYTHON_VERSION="${PYTHON_VERSION}"\
+ PYTHON_INCLUDES="${PYTHON_INCLUDEDIR}"\
+ PYTHON_LIB_PATH="${PYTHON_LIBDIR}"
+
+RUN_DEPENDS+= ${PREFIX}/lib/libboost_thread.so.${BOOST_SHARED_LIB_VER}:${PORTSDIR}/devel/boost-libs
+RUN_DEPENDS+= gccxml:${PORTSDIR}/devel/gccxml \
+ ${PYTHON_SITELIBDIR}/elementtree/ElementTree.py:${PORTSDIR}/devel/py-elementtree
+
+BUILD_DEPENDS+= ${BJAM}:${PORTSDIR}/devel/boost-jam
+BUILD_DEPENDS+= ${PYTHON_SITELIBDIR}/elementtree/ElementTree.py:${PORTSDIR}/devel/py-elementtree
+
+ESCAPED_PREFIX != echo ${PREFIX} | sed 's/\//\\\//g'
+RELATIVE_PYTHON_SITELIBDIR != echo ${PYTHON_SITELIBDIR} | sed "s/${ESCAPED_PREFIX}\///"
+PLIST_SUB+= PYTHON_SITELIBDIR=${RELATIVE_PYTHON_SITELIBDIR}
+PLIST_SUB+= PYTHON_VERSION=${PYTHON_VERSION:C/python//1}
+
+post-patch: customize-boost-build
+
+
+post-configure:
+# Configure pyste, the Boost.Python code generator
+ @cd ${BUILD_WRKSRC}/libs/python/pyste/install && \
+ ${SETENV} ${MAKE_ENV} ${PYTHON_CMD} ${PYSETUP} \
+ config ${PYDISTUTILS_CONFIGUREARGS}
+
+do-build:
+# build the library
+ cd ${WRKSRC} && \
+ ${SETENV} ${MAKE_ENV} ${BJAM} ${BJAM_OPTIONS} --prefix=${PREFIX}\
+ --toolset=${BOOST_TOOLS} --with-python
+
+# Build pyste, the Boost.Python code generator
+ cd ${BUILD_WRKSRC}/libs/python/pyste/install && \
+ ${SETENV} ${MAKE_ENV} ${PYTHON_CMD} ${PYSETUP} \
+ build ${PYDISTUTILS_BUILDARGS}
+
+# Remove non-python headers
+ cd ${WRKSRC} && \
+ ${FIND} boost -not -path '*python*' -delete
+
+do-install:
+# Install libraries
+ ${INSTALL_DATA} ${WRKSRC}/bin.v2/libs/python/build/gcc-4.2.1/release/link-static/threading-multi/libboost_python.a ${PREFIX}/lib
+ ${INSTALL_DATA} ${WRKSRC}/bin.v2/libs/python/build/gcc-4.2.1/release/threading-multi/libboost_python.so.${PORTVERSION} ${PREFIX}/lib/libboost_python.so.${BOOST_SHARED_LIB_VER}
+
+# Create symlink for shared library
+ cd ${PREFIX}/lib/ && \
+ ${LN} -fs "libboost_python.so.${BOOST_SHARED_LIB_VER}" "libboost_python.so"
+
+# Install headers
+ cd ${WRKSRC} && \
+ ${FIND} boost -type d -a \! -name "*.orig"\
+ -exec ${MKDIR} ${PREFIX}/include/\{\} \;
+
+ cd ${WRKSRC} && \
+ ${FIND} boost -type f -a \! -name "*.orig"\
+ -exec ${INSTALL_DATA} \{\} ${PREFIX}/include/\{\} \;
+
+# Install pyste, the Boost.Python code generator
+ cd ${WRKSRC}/libs/python/pyste/install && \
+ ${SETENV} ${MAKE_ENV} ${PYTHON_CMD} ${PYSETUP} \
+ install ${PYDISTUTILS_INSTALLARGS}
+
+post-install:
+# display pkg-message
+ @${TOUCH} ${PKGMESSAGE}
+ @${CAT} ${PKG_MESSAGE_FILE_THREADS} >> ${PKGMESSAGE}
+ @${ECHO_CMD} >> ${PKGMESSAGE}
+ @${CAT} ${PKG_MESSAGE_FILE_PYTHON} >> ${PKGMESSAGE}
+ @${ECHO_CMD} >> ${PKGMESSAGE}
+ @${REINPLACE_CMD} \
+ -e "s|%%LOCALBASE%%|${LOCALBASE}|g" \
+ -e "s|%%PTHREAD_LIBS%%|${PTHREAD_LIBS}|g" \
+ -e "s|%%PYTHON_INCLUDEDIR%%|${PYTHON_INCLUDEDIR}|g" \
+ -e "s|%%PYTHON_LIBDIR%%|${PYTHON_LIBDIR}|g" \
+ -e "s|%%PYTHON_VERSION%%|${PYTHON_VERSION}|g" ${PKGMESSAGE}
+ @if [ -s ${PKGMESSAGE} ]; then \
+ ${ECHO_CMD} ; \
+ ${ECHO_CMD} "===============================================================================" ; \
+ ${ECHO_CMD} ; \
+ ${CAT} ${PKGMESSAGE}; \
+ ${ECHO_CMD} "===============================================================================" ; \
+ ${ECHO_CMD} ; \
+ fi
+
+.include <bsd.port.post.mk>
diff --git a/devel/boost-python-libs/distinfo b/devel/boost-python-libs/distinfo
new file mode 100644
index 000000000000..72159a820690
--- /dev/null
+++ b/devel/boost-python-libs/distinfo
@@ -0,0 +1,3 @@
+MD5 (boost_1_39_0.tar.bz2) = a17281fd88c48e0d866e1a12deecbcc0
+SHA256 (boost_1_39_0.tar.bz2) = 44785eae8c6cce61a29a8a51f9b737e57b34d66baa7c0bcd4af188832b8018fd
+SIZE (boost_1_39_0.tar.bz2) = 29408537
diff --git a/devel/boost-python-libs/files/patch-tools_build_v2_tools_common.jam b/devel/boost-python-libs/files/patch-tools_build_v2_tools_common.jam
new file mode 100644
index 000000000000..68683f173aee
--- /dev/null
+++ b/devel/boost-python-libs/files/patch-tools_build_v2_tools_common.jam
@@ -0,0 +1,17 @@
+--- tools/build/v2/tools/common.jam.orig Thu Oct 16 12:42:03 2008
++++ tools/build/v2/tools/common.jam Tue Nov 11 23:43:27 2008
+@@ -760,14 +760,6 @@
+ result += [ join-tag $(f:G=) : [ toolset-tag $(name) : $(type) :
+ $(property-set) ] ] ;
+
+- case <threading> :
+- result += [ join-tag $(f:G=) : [ threading-tag $(name) : $(type)
+- : $(property-set) ] ] ;
+-
+- case <runtime> :
+- result += [ join-tag $(f:G=) : [ runtime-tag $(name) : $(type) :
+- $(property-set) ] ] ;
+-
+ case <version:*> :
+ local key = [ MATCH <version:(.*)> : $(f:G) ] ;
+ local version = [ $(property-set).get <$(key)> ] ;
diff --git a/devel/boost-python-libs/files/patch-tools_build_v2_tools_gcc.jam b/devel/boost-python-libs/files/patch-tools_build_v2_tools_gcc.jam
new file mode 100644
index 000000000000..f370c8237dae
--- /dev/null
+++ b/devel/boost-python-libs/files/patch-tools_build_v2_tools_gcc.jam
@@ -0,0 +1,54 @@
+--- tools/build/v2/tools/gcc.jam.orig Thu Oct 16 12:42:03 2008
++++ tools/build/v2/tools/gcc.jam Tue Nov 11 23:48:37 2008
+@@ -88,7 +88,7 @@
+ {
+ # Information about the gcc command...
+ # The command.
+- local command = [ common.get-invocation-command gcc : g++ : $(command) ] ;
++ local command = [ common.get-invocation-command gcc : %%CXX%% : $(command) ] ;
+ # The root directory of the tool install.
+ local root = [ feature.get-values <root> : $(options) ] ;
+ # The bin directory where to find the command to execute.
+@@ -292,7 +292,7 @@
+
+ # Declare flags and action for compilation.
+ toolset.flags gcc.compile OPTIONS <optimization>off : -O0 ;
+-toolset.flags gcc.compile OPTIONS <optimization>speed : -O3 ;
++toolset.flags gcc.compile OPTIONS <optimization>speed : %%CXXFLAGS%% ;
+ toolset.flags gcc.compile OPTIONS <optimization>space : -Os ;
+
+ toolset.flags gcc.compile OPTIONS <inlining>off : -fno-inline ;
+@@ -349,15 +349,6 @@
+ }
+ }
+
+-# FIXME: this should not use os.name.
+-if [ os.name ] != NT && [ os.name ] != OSF && [ os.name ] != HPUX && [ os.name ] != AIX
+-{
+- # OSF does have an option called -soname but it does not seem to work as
+- # expected, therefore it has been disabled.
+- HAVE_SONAME = "" ;
+- SONAME_OPTION = -h ;
+-}
+-
+
+ toolset.flags gcc.compile USER_OPTIONS <cflags> ;
+ toolset.flags gcc.compile.c++ USER_OPTIONS <cxxflags> ;
+@@ -793,7 +784,7 @@
+ # Differs from 'link' above only by -shared.
+ actions link.dll bind LIBRARIES
+ {
+- "$(CONFIG_COMMAND)" -L"$(LINKPATH)" -Wl,$(RPATH_OPTION:E=-R)$(SPACE)-Wl,"$(RPATH)" "$(.IMPLIB-COMMAND)$(<[1])" -o "$(<[-1])" $(HAVE_SONAME)-Wl,$(SONAME_OPTION)$(SPACE)-Wl,$(<[-1]:D=) -shared $(START-GROUP) "$(>)" "$(LIBRARIES)" $(FINDLIBS-ST-PFX) -l$(FINDLIBS-ST) $(FINDLIBS-SA-PFX) -l$(FINDLIBS-SA) $(END-GROUP) $(OPTIONS) $(USER_OPTIONS)
++ "$(CONFIG_COMMAND)" -L"$(LINKPATH)" -Wl,$(RPATH_OPTION:E=-R)$(SPACE)-Wl,"$(RPATH)" "$(.IMPLIB-COMMAND)$(<[1])" -o "$(<[-1])" -shared $(START-GROUP) "$(>)" "$(LIBRARIES)" $(FINDLIBS-ST-PFX) -l$(FINDLIBS-ST) $(FINDLIBS-SA-PFX) -l$(FINDLIBS-SA) $(END-GROUP) $(OPTIONS) $(USER_OPTIONS)
+ }
+
+ rule setup-threading ( targets * : sources * : properties * )
+@@ -811,7 +811,7 @@
+ }
+ case *bsd :
+ {
+- option = -pthread ;
++ option = %%PTHREAD_LIBS%% %%PTHREAD_CFLAGS%% ;
+ # There is no -lrt on BSD.
+ }
+ case sgi :
diff --git a/devel/boost-python-libs/files/patch-tools_build_v2_tools_python.jam b/devel/boost-python-libs/files/patch-tools_build_v2_tools_python.jam
new file mode 100644
index 000000000000..bf2212b3d520
--- /dev/null
+++ b/devel/boost-python-libs/files/patch-tools_build_v2_tools_python.jam
@@ -0,0 +1,11 @@
+--- tools/build/v2/tools/python.jam.orig Thu Oct 16 12:42:03 2008
++++ tools/build/v2/tools/python.jam Tue Nov 11 23:50:21 2008
+@@ -650,7 +650,7 @@
+ case windows : return ;
+
+ case hpux : return <library>rt ;
+- case *bsd : return <library>pthread <toolset>gcc:<library>util ;
++ case *bsd : return <library>%%PTHREAD_LIBS%% <toolset>gcc:<library>util ;
+
+ case aix : return <library>pthread <library>dl ;
+
diff --git a/devel/boost-python-libs/files/patch-tools_jam_src_build.jam b/devel/boost-python-libs/files/patch-tools_jam_src_build.jam
new file mode 100644
index 000000000000..413fef332db7
--- /dev/null
+++ b/devel/boost-python-libs/files/patch-tools_jam_src_build.jam
@@ -0,0 +1,11 @@
+--- tools/jam/src/build.jam.orig Tue Jul 29 15:43:31 2008
++++ tools/jam/src/build.jam Tue Nov 11 23:52:09 2008
+@@ -176,7 +176,7 @@
+ ## GCC 2.x, 3.x, 4.x
+ toolset gcc gcc : "-o " : -D
+ : -pedantic -fno-strict-aliasing
+- [ opt --release : [ opt --symbols : -g : -s ] -O3 ]
++ [ opt --release : [ opt --symbols : -g : -s ] -O3 -fno-strict-aliasing ]
+ [ opt --debug : -g -O0 -fno-inline ]
+ -I$(--python-include) -I$(--extra-include) -Wno-long-long
+ : -L$(--python-lib[1]) -l$(--python-lib[2]) ;
diff --git a/devel/boost-python-libs/pkg-descr b/devel/boost-python-libs/pkg-descr
new file mode 100644
index 000000000000..0401922628a4
--- /dev/null
+++ b/devel/boost-python-libs/pkg-descr
@@ -0,0 +1,6 @@
+The Boost Python Library is a framework for interfacing Python and
+C++. It allows you to quickly and seamlessly expose C++ classes
+functions and objects to Python, and vice-versa, using no special
+tools -- just your C++ compiler.
+
+WWW: http://www.boost.org/
diff --git a/devel/boost-python-libs/pkg-plist b/devel/boost-python-libs/pkg-plist
new file mode 100644
index 000000000000..8e7afac2f87b
--- /dev/null
+++ b/devel/boost-python-libs/pkg-plist
@@ -0,0 +1,287 @@
+bin/pyste.py
+include/boost/python.hpp
+include/boost/python/arg_from_python.hpp
+include/boost/python/args.hpp
+include/boost/python/args_fwd.hpp
+include/boost/python/back_reference.hpp
+include/boost/python/base_type_traits.hpp
+include/boost/python/bases.hpp
+include/boost/python/borrowed.hpp
+include/boost/python/call.hpp
+include/boost/python/call_method.hpp
+include/boost/python/cast.hpp
+include/boost/python/class.hpp
+include/boost/python/class_fwd.hpp
+include/boost/python/converter/arg_from_python.hpp
+include/boost/python/converter/arg_to_python.hpp
+include/boost/python/converter/arg_to_python_base.hpp
+include/boost/python/converter/as_to_python_function.hpp
+include/boost/python/converter/builtin_converters.hpp
+include/boost/python/converter/constructor_function.hpp
+include/boost/python/converter/context_result_converter.hpp
+include/boost/python/converter/convertible_function.hpp
+include/boost/python/converter/from_python.hpp
+include/boost/python/converter/implicit.hpp
+include/boost/python/converter/obj_mgr_arg_from_python.hpp
+include/boost/python/converter/object_manager.hpp
+include/boost/python/converter/pointer_type_id.hpp
+include/boost/python/converter/pyobject_traits.hpp
+include/boost/python/converter/pyobject_type.hpp
+include/boost/python/converter/pytype_function.hpp
+include/boost/python/converter/pytype_object_mgr_traits.hpp
+include/boost/python/converter/registered.hpp
+include/boost/python/converter/registered_pointee.hpp
+include/boost/python/converter/registrations.hpp
+include/boost/python/converter/registry.hpp
+include/boost/python/converter/return_from_python.hpp
+include/boost/python/converter/rvalue_from_python_data.hpp
+include/boost/python/converter/shared_ptr_deleter.hpp
+include/boost/python/converter/shared_ptr_from_python.hpp
+include/boost/python/converter/shared_ptr_to_python.hpp
+include/boost/python/converter/to_python_function_type.hpp
+include/boost/python/copy_const_reference.hpp
+include/boost/python/copy_non_const_reference.hpp
+include/boost/python/data_members.hpp
+include/boost/python/def.hpp
+include/boost/python/def_visitor.hpp
+include/boost/python/default_call_policies.hpp
+include/boost/python/detail/aix_init_module.hpp
+include/boost/python/detail/api_placeholder.hpp
+include/boost/python/detail/borrowed_ptr.hpp
+include/boost/python/detail/caller.hpp
+include/boost/python/detail/config.hpp
+include/boost/python/detail/construct.hpp
+include/boost/python/detail/convertible.hpp
+include/boost/python/detail/copy_ctor_mutates_rhs.hpp
+include/boost/python/detail/cv_category.hpp
+include/boost/python/detail/dealloc.hpp
+include/boost/python/detail/decorated_type_id.hpp
+include/boost/python/detail/decref_guard.hpp
+include/boost/python/detail/def_helper.hpp
+include/boost/python/detail/def_helper_fwd.hpp
+include/boost/python/detail/defaults_def.hpp
+include/boost/python/detail/defaults_gen.hpp
+include/boost/python/detail/dependent.hpp
+include/boost/python/detail/destroy.hpp
+include/boost/python/detail/enable_if.hpp
+include/boost/python/detail/exception_handler.hpp
+include/boost/python/detail/force_instantiate.hpp
+include/boost/python/detail/if_else.hpp
+include/boost/python/detail/indirect_traits.hpp
+include/boost/python/detail/invoke.hpp
+include/boost/python/detail/is_auto_ptr.hpp
+include/boost/python/detail/is_shared_ptr.hpp
+include/boost/python/detail/is_wrapper.hpp
+include/boost/python/detail/is_xxx.hpp
+include/boost/python/detail/make_keyword_range_fn.hpp
+include/boost/python/detail/make_tuple.hpp
+include/boost/python/detail/map_entry.hpp
+include/boost/python/detail/mpl_lambda.hpp
+include/boost/python/detail/msvc_typeinfo.hpp
+include/boost/python/detail/none.hpp
+include/boost/python/detail/not_specified.hpp
+include/boost/python/detail/nullary_function_adaptor.hpp
+include/boost/python/detail/operator_id.hpp
+include/boost/python/detail/overloads_fwd.hpp
+include/boost/python/detail/pointee.hpp
+include/boost/python/detail/prefix.hpp
+include/boost/python/detail/preprocessor.hpp
+include/boost/python/detail/python22_fixed.h
+include/boost/python/detail/python_type.hpp
+include/boost/python/detail/raw_pyobject.hpp
+include/boost/python/detail/referent_storage.hpp
+include/boost/python/detail/result.hpp
+include/boost/python/detail/scope.hpp
+include/boost/python/detail/sfinae.hpp
+include/boost/python/detail/signature.hpp
+include/boost/python/detail/string_literal.hpp
+include/boost/python/detail/target.hpp
+include/boost/python/detail/translate_exception.hpp
+include/boost/python/detail/type_list.hpp
+include/boost/python/detail/type_list_impl.hpp
+include/boost/python/detail/type_list_impl_no_pts.hpp
+include/boost/python/detail/unwind_type.hpp
+include/boost/python/detail/unwrap_type_id.hpp
+include/boost/python/detail/unwrap_wrapper.hpp
+include/boost/python/detail/value_arg.hpp
+include/boost/python/detail/value_is_shared_ptr.hpp
+include/boost/python/detail/value_is_xxx.hpp
+include/boost/python/detail/void_ptr.hpp
+include/boost/python/detail/void_return.hpp
+include/boost/python/detail/wrap_python.hpp
+include/boost/python/detail/wrapper_base.hpp
+include/boost/python/dict.hpp
+include/boost/python/docstring_options.hpp
+include/boost/python/enum.hpp
+include/boost/python/errors.hpp
+include/boost/python/exception_translator.hpp
+include/boost/python/exec.hpp
+include/boost/python/extract.hpp
+include/boost/python/handle.hpp
+include/boost/python/handle_fwd.hpp
+include/boost/python/has_back_reference.hpp
+include/boost/python/implicit.hpp
+include/boost/python/import.hpp
+include/boost/python/init.hpp
+include/boost/python/instance_holder.hpp
+include/boost/python/iterator.hpp
+include/boost/python/list.hpp
+include/boost/python/long.hpp
+include/boost/python/lvalue_from_pytype.hpp
+include/boost/python/make_constructor.hpp
+include/boost/python/make_function.hpp
+include/boost/python/manage_new_object.hpp
+include/boost/python/module.hpp
+include/boost/python/module_init.hpp
+include/boost/python/numeric.hpp
+include/boost/python/object.hpp
+include/boost/python/object/add_to_namespace.hpp
+include/boost/python/object/class.hpp
+include/boost/python/object/class_detail.hpp
+include/boost/python/object/class_metadata.hpp
+include/boost/python/object/class_wrapper.hpp
+include/boost/python/object/enum_base.hpp
+include/boost/python/object/find_instance.hpp
+include/boost/python/object/forward.hpp
+include/boost/python/object/function.hpp
+include/boost/python/object/function_doc_signature.hpp
+include/boost/python/object/function_handle.hpp
+include/boost/python/object/function_object.hpp
+include/boost/python/object/inheritance.hpp
+include/boost/python/object/inheritance_query.hpp
+include/boost/python/object/instance.hpp
+include/boost/python/object/iterator.hpp
+include/boost/python/object/iterator_core.hpp
+include/boost/python/object/life_support.hpp
+include/boost/python/object/make_holder.hpp
+include/boost/python/object/make_instance.hpp
+include/boost/python/object/make_ptr_instance.hpp
+include/boost/python/object/pickle_support.hpp
+include/boost/python/object/pointer_holder.hpp
+include/boost/python/object/py_function.hpp
+include/boost/python/object/stl_iterator_core.hpp
+include/boost/python/object/value_holder.hpp
+include/boost/python/object/value_holder_fwd.hpp
+include/boost/python/object_attributes.hpp
+include/boost/python/object_call.hpp
+include/boost/python/object_core.hpp
+include/boost/python/object_fwd.hpp
+include/boost/python/object_items.hpp
+include/boost/python/object_operators.hpp
+include/boost/python/object_protocol.hpp
+include/boost/python/object_protocol_core.hpp
+include/boost/python/object_slices.hpp
+include/boost/python/opaque_pointer_converter.hpp
+include/boost/python/operators.hpp
+include/boost/python/other.hpp
+include/boost/python/overloads.hpp
+include/boost/python/override.hpp
+include/boost/python/pointee.hpp
+include/boost/python/proxy.hpp
+include/boost/python/ptr.hpp
+include/boost/python/pure_virtual.hpp
+include/boost/python/raw_function.hpp
+include/boost/python/refcount.hpp
+include/boost/python/reference_existing_object.hpp
+include/boost/python/register_ptr_to_python.hpp
+include/boost/python/return_arg.hpp
+include/boost/python/return_by_value.hpp
+include/boost/python/return_internal_reference.hpp
+include/boost/python/return_opaque_pointer.hpp
+include/boost/python/return_value_policy.hpp
+include/boost/python/scope.hpp
+include/boost/python/self.hpp
+include/boost/python/signature.hpp
+include/boost/python/slice.hpp
+include/boost/python/slice_nil.hpp
+include/boost/python/ssize_t.hpp
+include/boost/python/stl_iterator.hpp
+include/boost/python/str.hpp
+include/boost/python/suite/indexing/container_utils.hpp
+include/boost/python/suite/indexing/detail/indexing_suite_detail.hpp
+include/boost/python/suite/indexing/indexing_suite.hpp
+include/boost/python/suite/indexing/map_indexing_suite.hpp
+include/boost/python/suite/indexing/vector_indexing_suite.hpp
+include/boost/python/tag.hpp
+include/boost/python/to_python_converter.hpp
+include/boost/python/to_python_indirect.hpp
+include/boost/python/to_python_value.hpp
+include/boost/python/tuple.hpp
+include/boost/python/type_id.hpp
+include/boost/python/with_custodian_and_ward.hpp
+include/boost/python/wrapper.hpp
+lib/libboost_python.a
+lib/libboost_python.so
+lib/libboost_python.so.%%BOOST_SHARED_LIB_VER%%
+%%PYTHON_SITELIBDIR%%/Pyste-0.9.10-py%%PYTHON_VERSION%%.egg-info
+%%PYTHON_SITELIBDIR%%/Pyste/ClassExporter.py
+%%PYTHON_SITELIBDIR%%/Pyste/ClassExporter.pyc
+%%PYTHON_SITELIBDIR%%/Pyste/ClassExporter.pyo
+%%PYTHON_SITELIBDIR%%/Pyste/CodeExporter.py
+%%PYTHON_SITELIBDIR%%/Pyste/CodeExporter.pyc
+%%PYTHON_SITELIBDIR%%/Pyste/CodeExporter.pyo
+%%PYTHON_SITELIBDIR%%/Pyste/CppParser.py
+%%PYTHON_SITELIBDIR%%/Pyste/CppParser.pyc
+%%PYTHON_SITELIBDIR%%/Pyste/CppParser.pyo
+%%PYTHON_SITELIBDIR%%/Pyste/EnumExporter.py
+%%PYTHON_SITELIBDIR%%/Pyste/EnumExporter.pyc
+%%PYTHON_SITELIBDIR%%/Pyste/EnumExporter.pyo
+%%PYTHON_SITELIBDIR%%/Pyste/Exporter.py
+%%PYTHON_SITELIBDIR%%/Pyste/Exporter.pyc
+%%PYTHON_SITELIBDIR%%/Pyste/Exporter.pyo
+%%PYTHON_SITELIBDIR%%/Pyste/FunctionExporter.py
+%%PYTHON_SITELIBDIR%%/Pyste/FunctionExporter.pyc
+%%PYTHON_SITELIBDIR%%/Pyste/FunctionExporter.pyo
+%%PYTHON_SITELIBDIR%%/Pyste/GCCXMLParser.py
+%%PYTHON_SITELIBDIR%%/Pyste/GCCXMLParser.pyc
+%%PYTHON_SITELIBDIR%%/Pyste/GCCXMLParser.pyo
+%%PYTHON_SITELIBDIR%%/Pyste/HeaderExporter.py
+%%PYTHON_SITELIBDIR%%/Pyste/HeaderExporter.pyc
+%%PYTHON_SITELIBDIR%%/Pyste/HeaderExporter.pyo
+%%PYTHON_SITELIBDIR%%/Pyste/MultipleCodeUnit.py
+%%PYTHON_SITELIBDIR%%/Pyste/MultipleCodeUnit.pyc
+%%PYTHON_SITELIBDIR%%/Pyste/MultipleCodeUnit.pyo
+%%PYTHON_SITELIBDIR%%/Pyste/SingleCodeUnit.py
+%%PYTHON_SITELIBDIR%%/Pyste/SingleCodeUnit.pyc
+%%PYTHON_SITELIBDIR%%/Pyste/SingleCodeUnit.pyo
+%%PYTHON_SITELIBDIR%%/Pyste/SmartFile.py
+%%PYTHON_SITELIBDIR%%/Pyste/SmartFile.pyc
+%%PYTHON_SITELIBDIR%%/Pyste/SmartFile.pyo
+%%PYTHON_SITELIBDIR%%/Pyste/VarExporter.py
+%%PYTHON_SITELIBDIR%%/Pyste/VarExporter.pyc
+%%PYTHON_SITELIBDIR%%/Pyste/VarExporter.pyo
+%%PYTHON_SITELIBDIR%%/Pyste/__init__.py
+%%PYTHON_SITELIBDIR%%/Pyste/__init__.pyc
+%%PYTHON_SITELIBDIR%%/Pyste/__init__.pyo
+%%PYTHON_SITELIBDIR%%/Pyste/declarations.py
+%%PYTHON_SITELIBDIR%%/Pyste/declarations.pyc
+%%PYTHON_SITELIBDIR%%/Pyste/declarations.pyo
+%%PYTHON_SITELIBDIR%%/Pyste/exporters.py
+%%PYTHON_SITELIBDIR%%/Pyste/exporters.pyc
+%%PYTHON_SITELIBDIR%%/Pyste/exporters.pyo
+%%PYTHON_SITELIBDIR%%/Pyste/exporterutils.py
+%%PYTHON_SITELIBDIR%%/Pyste/exporterutils.pyc
+%%PYTHON_SITELIBDIR%%/Pyste/exporterutils.pyo
+%%PYTHON_SITELIBDIR%%/Pyste/infos.py
+%%PYTHON_SITELIBDIR%%/Pyste/infos.pyc
+%%PYTHON_SITELIBDIR%%/Pyste/infos.pyo
+%%PYTHON_SITELIBDIR%%/Pyste/policies.py
+%%PYTHON_SITELIBDIR%%/Pyste/policies.pyc
+%%PYTHON_SITELIBDIR%%/Pyste/policies.pyo
+%%PYTHON_SITELIBDIR%%/Pyste/pyste.py
+%%PYTHON_SITELIBDIR%%/Pyste/pyste.pyc
+%%PYTHON_SITELIBDIR%%/Pyste/pyste.pyo
+%%PYTHON_SITELIBDIR%%/Pyste/settings.py
+%%PYTHON_SITELIBDIR%%/Pyste/settings.pyc
+%%PYTHON_SITELIBDIR%%/Pyste/settings.pyo
+%%PYTHON_SITELIBDIR%%/Pyste/utils.py
+%%PYTHON_SITELIBDIR%%/Pyste/utils.pyc
+%%PYTHON_SITELIBDIR%%/Pyste/utils.pyo
+@dirrm %%PYTHON_SITELIBDIR%%/Pyste
+@dirrm include/boost/python/suite/indexing/detail
+@dirrm include/boost/python/suite/indexing
+@dirrm include/boost/python/suite
+@dirrm include/boost/python/object
+@dirrm include/boost/python/detail
+@dirrm include/boost/python/converter
+@dirrm include/boost/python