aboutsummaryrefslogtreecommitdiff
path: root/devel/bzr/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/bzr/Makefile')
-rw-r--r--devel/bzr/Makefile12
1 files changed, 10 insertions, 2 deletions
diff --git a/devel/bzr/Makefile b/devel/bzr/Makefile
index d0a50e8213ef..ced13df9f3da 100644
--- a/devel/bzr/Makefile
+++ b/devel/bzr/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= bazaar-ng
-PORTVERSION= 0.18
+PORTVERSION= 0.90
CATEGORIES= devel
MASTER_SITES= http://bazaar-vcs.org/releases/src/
MASTER_SITE_SUBDIR= gnu-arch
@@ -17,6 +17,8 @@ COMMENT= Distributed version control system by Canonical
RUN_DEPENDS= ${PYTHON_SITELIBDIR}/cElementTree.so:${PORTSDIR}/devel/py-celementtree
+OPTIONS= SFTP "Enable Paramiko for SFTP support" on
+
USE_PYTHON= 2.4+
USE_PYDISTUTILS= yes
PYDISTUTILS_PKGNAME= bzr
@@ -24,10 +26,16 @@ PYDISTUTILS_PKGVERSION= ${PORTVERSION}.0
MAN1= bzr.1
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_SFTP)
+RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/paramiko/__init__.py:${PORTSDIR}/security/py-paramiko
+.endif
+
post-install:
${INSTALL_MAN} ${WRKSRC}/bzr.1 ${MAN1PREFIX}/man/man1
test: build
cd ${WRKSRC} && ./bzr selftest
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>