aboutsummaryrefslogtreecommitdiff
path: root/devel/cccc
diff options
context:
space:
mode:
Diffstat (limited to 'devel/cccc')
-rw-r--r--devel/cccc/Makefile15
1 files changed, 5 insertions, 10 deletions
diff --git a/devel/cccc/Makefile b/devel/cccc/Makefile
index 4185a2039615..1e5b1f001ffc 100644
--- a/devel/cccc/Makefile
+++ b/devel/cccc/Makefile
@@ -12,24 +12,19 @@ COMMENT= C and C++ Code Counter
BUILD_DEPENDS= antlr:${PORTSDIR}/devel/pccts \
dlg:${PORTSDIR}/devel/pccts
-USE_GMAKE= yes
+USES= gmake
MAKEFILE= makefile
MAKE_JOBS_UNSAFE= yes
+MAKE_ARGS= CCC="${CXX}"
PORTDOCS= readme.txt changes.txt
PLIST_FILES= bin/cccc
-NO_STAGE= yes
-post-patch:
- @${REINPLACE_CMD} -e 's|=g++|=${CXX}|' ${WRKSRC}/*/posix*.mak
-
do-install:
- @${INSTALL_PROGRAM} ${WRKSRC}/cccc/cccc ${PREFIX}/bin
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
+ @${INSTALL_PROGRAM} ${WRKSRC}/cccc/cccc ${STAGEDIR}${PREFIX}/bin
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
.for f in ${PORTDOCS}
- @${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${DOCSDIR}
.endfor
-.endif
.include <bsd.port.mk>