aboutsummaryrefslogtreecommitdiff
path: root/devel/cedet/files/patch-speedbar-Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/cedet/files/patch-speedbar-Makefile')
-rw-r--r--devel/cedet/files/patch-speedbar-Makefile41
1 files changed, 41 insertions, 0 deletions
diff --git a/devel/cedet/files/patch-speedbar-Makefile b/devel/cedet/files/patch-speedbar-Makefile
new file mode 100644
index 000000000000..dc5cf33a3128
--- /dev/null
+++ b/devel/cedet/files/patch-speedbar-Makefile
@@ -0,0 +1,41 @@
+--- speedbar/Makefile.orig 2010-05-04 22:50:41.000000000 +0200
++++ speedbar/Makefile 2010-05-04 22:52:07.000000000 +0200
+@@ -18,7 +18,7 @@
+ EMACSFLAGS=-batch --no-site-file
+ speedbar_LISP=dframe.el speedbar.el
+ info_TEXINFOS=speedbar.texi
+-MAKEINFO=makeinfo
++MAKEINFO=makeinfo --force --no-split
+ opt_LISP=rpm.el sb-gud.el sb-info.el sb-rmail.el sb-w3.el sb-texinfo.el bigclock.el sb-html.el sb-ant.el
+ aux_AUX=INSTALL ChangeLog
+ images_MISC=sb-dir-plus.xpm sb-dir-minus.xpm sb-dir.xpm sb-pg-plus.xpm sb-pg-minus.xpm sb-pg.xpm sb-mail.xpm sb-tag-plus.xpm sb-tag-minus.xpm sb-tag.xpm sb-tag-gt.xpm sb-tag-v.xpm sb-tag-type.xpm sb-image.el sb-obj.xpm sb-chk.xpm sb-objod.xpm sb-label.xpm sb-ro.xpm sb-doc.xpm sb-info.xpm sb-doc-plus.xpm sb-doc-minus.xpm sb-box.xpm sb-box-plus.xpm sb-box-minus.xpm
+@@ -27,7 +27,7 @@
+
+
+
+-all: autoloads init speedbar speedbar.info
++all: autoloads init speedbar speedbar-cedet.info
+
+ .PHONY: autoloads
+ autoloads:
+@@ -56,7 +56,7 @@
+ @echo "(setq debug-on-error t)" >> $@-compile-script
+ "$(EMACS)" $(EMACSFLAGS) -l $@-compile-script -f batch-byte-compile $^
+
+-speedbar.info: $(info_TEXINFOS)
++speedbar-cedet.info: $(info_TEXINFOS)
+ $(MAKEINFO) $<
+
+ .PHONY: opt
+@@ -79,9 +79,9 @@
+
+ .PHONY: dist
+
+-dist: autoloads speedbar.info
++dist: autoloads speedbar-cedet.info
+ mkdir $(DISTDIR)
+- cp speedbar-loaddefs.el $(init_LISP) $(speedbar_LISP) $(info_TEXINFOS) speedbar.info* $(opt_LISP) $(aux_AUX) $(images_MISC) $(ede_FILES) $(DISTDIR)
++ cp speedbar-loaddefs.el $(init_LISP) $(speedbar_LISP) $(info_TEXINFOS) speedbar-cedet.info* $(opt_LISP) $(aux_AUX) $(images_MISC) $(ede_FILES) $(DISTDIR)
+
+ Makefile: Project.ede
+ @echo Makefile is out of date! It needs to be regenerated by EDE.