aboutsummaryrefslogtreecommitdiff
path: root/devel/cgilib/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/cgilib/Makefile')
-rw-r--r--devel/cgilib/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/devel/cgilib/Makefile b/devel/cgilib/Makefile
new file mode 100644
index 000000000000..172c173e1cb8
--- /dev/null
+++ b/devel/cgilib/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: cgilib
+# Date created: 8 May 2005
+# Whom: Dmitry Sivachenko <demon@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= cgilib
+PORTVERSION= 0.5
+CATEGORIES= devel www
+MASTER_SITES= http://people.ee.ethz.ch/~oetiker/webtools/rrdtool/pub/libs/
+
+MAINTAINER= demon@FreeBSD.org
+COMMENT= A library of procedures for developing CGI programs in C
+
+INSTALLS_SHLIB= yes
+
+MAKEFILE= ${FILESDIR}/Makefile.bsd
+
+MAN3= cgiDebug.3 cgiFree.3 cgiFreeList.3 cgiGetCookie.3 \
+ cgiGetCookies.3 cgiGetValue.3 cgiGetVariables.3 cgiHeader.3 \
+ cgiInit.3 cgiRedirect.3 cgiSetHeader.3 cgiSetType.3
+
+post-install:
+ ${INSTALL_DATA} ${WRKSRC}/cgi.h ${PREFIX}/include
+ ${INSTALL_MAN} ${WRKSRC}/*.3 ${PREFIX}/man/man3
+
+.include <bsd.port.mk>