aboutsummaryrefslogtreecommitdiff
path: root/devel/cgit/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/cgit/Makefile')
-rw-r--r--devel/cgit/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/devel/cgit/Makefile b/devel/cgit/Makefile
index f454d3827c9a..c422eb2af768 100644
--- a/devel/cgit/Makefile
+++ b/devel/cgit/Makefile
@@ -7,13 +7,13 @@
PORTNAME= cgit
PORTVERSION= 0.9.0.2
+PORTREVISION= 1
CATEGORIES= devel www
MASTER_SITES= http://hjemli.net/git/cgit/snapshot/:cgit \
${MASTER_SITE_KERNEL_ORG:S/$/:git/g}
MASTER_SITE_SUBDIR= software/scm/git/:git
DISTFILES= cgit-${PORTVERSION}${EXTRACT_SUFX}:cgit \
git-${GIT_VERSION}.tar.bz2:git
-GIT_VERSION= 1.7.4
MAINTAINER= bapt@FreeBSD.org
COMMENT= A fast webinterface for git
@@ -21,6 +21,7 @@ COMMENT= A fast webinterface for git
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
+GIT_VERSION= 1.7.4
USE_BZIP2= yes
USE_GMAKE= yes
USE_ICONV= yes
@@ -34,6 +35,7 @@ LDFLAGS+= -L${LOCALBASE}/lib
SUB_FILES= pkg-message
SUB_LIST+= PORTNAME=${PORTNAME}
+PLIST_SUB+= PORTNAME=${PORTNAME}
post-extract:
@${RMDIR} ${WRKSRC}/git
@@ -47,6 +49,7 @@ post-patch:
post-install:
@${MKDIR} /var/cache/${PORTNAME}
@${CHOWN} ${WWWOWN}:${WWWGRP} /var/cache/${PORTNAME}
+ @${CAT} ${PKGMESSAGE}
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/${PORTNAME}rc.5.txt ${DOCSDIR}/