aboutsummaryrefslogtreecommitdiff
path: root/devel/cgprof/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/cgprof/Makefile')
-rw-r--r--devel/cgprof/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/devel/cgprof/Makefile b/devel/cgprof/Makefile
new file mode 100644
index 000000000000..c4cd27513ed4
--- /dev/null
+++ b/devel/cgprof/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: cgprof
+# Date created: 16 December 2004
+# Whom: Adam McLaurin
+#
+# $FreeBSD$
+#
+
+PORTNAME= cgprof
+PORTVERSION= 1.2
+CATEGORIES= devel
+MASTER_SITES= http://mvertes.free.fr/download/
+
+MAINTAINER= adam.freebsd@fastmail.fm
+COMMENT= Generates colored graphs for profiled executables using gcc and gprof
+
+RUN_DEPENDS= gawk:${PORTSDIR}/lang/gawk \
+ dotty:${PORTSDIR}/graphics/graphviz
+
+NO_BUILD= yes
+MAKE_ENV= prefix=${PREFIX}
+
+MAN1= cgprof.1
+PLIST_FILES= bin/cgprof
+
+.include <bsd.port.mk>