aboutsummaryrefslogtreecommitdiff
path: root/devel/cl-split-sequence-sbcl
diff options
context:
space:
mode:
Diffstat (limited to 'devel/cl-split-sequence-sbcl')
-rw-r--r--devel/cl-split-sequence-sbcl/Makefile25
1 files changed, 8 insertions, 17 deletions
diff --git a/devel/cl-split-sequence-sbcl/Makefile b/devel/cl-split-sequence-sbcl/Makefile
index 9a6a04d1b447..fadbb679ba85 100644
--- a/devel/cl-split-sequence-sbcl/Makefile
+++ b/devel/cl-split-sequence-sbcl/Makefile
@@ -6,32 +6,23 @@
PORTNAME= split-sequence
PORTVERSION= 20011114.1
+PORTREVISION= 1
CATEGORIES= devel lisp
MASTER_SITES= ftp://ftp.linux.org.uk/pub/lisp/experimental/cclan/ \
ftp://ftp.ntnu.no/pub/lisp/cclan/ \
http://www-jcsu.jesus.cam.ac.uk/ftp/pub/cclan/
PKGNAMEPREFIX= cl-
-PKGNAMESUFFIX= -sbcl
-DISTFILES= # use installed sources from CL_LIBDIR
-EXTRACT_ONLY= # use installed sources from CL_LIBDIR
+DISTFILES= # none
MAINTAINER= olgeni@FreeBSD.org
COMMENT= Partitioning Common Lisp sequences
-BUILD_DEPENDS= ${LOCALBASE}/lib/common-lisp/split-sequence/split-sequence.asd:${PORTSDIR}/devel/cl-split-sequence \
- sbcl:${PORTSDIR}/lang/sbcl
-RUN_DEPENDS= ${LOCALBASE}/lib/common-lisp/split-sequence/split-sequence.asd:${PORTSDIR}/devel/cl-split-sequence \
- sbcl:${PORTSDIR}/lang/sbcl
+BUILD_DEPENDS= ${LOCALBASE}/${CL_LIBDIR_REL}/split-sequence/split-sequence.asd:${PORTSDIR}/devel/cl-split-sequence
+RUN_DEPENDS= ${LOCALBASE}/${CL_LIBDIR_REL}/split-sequence/split-sequence.asd:${PORTSDIR}/devel/cl-split-sequence
-do-build:
- @FBSD_ASDF_COMPILE_PORT=t WRKSRC=${WRKSRC}/ \
- sbcl --noinform --userinit /dev/null \
- --eval '#.(load "${LOCALBASE}/etc/asdf-init")' \
- --eval "(asdf:oos 'asdf:compile-op :split-sequence)" \
- --eval "(quit)"
-
-do-install:
- @${MKDIR} ${PREFIX}/lib/common-lisp/split-sequence/sbclfasl
- @${INSTALL_DATA} ${WRKSRC}/*.fasl ${PREFIX}/lib/common-lisp/split-sequence/sbclfasl/
+USE_ASDF_FASL= yes
+FASL_TARGET= sbcl
+FASL_BUILD= yes
+.include "${.CURDIR}/../../devel/cl-asdf/bsd.cl-asdf.mk"
.include <bsd.port.mk>