aboutsummaryrefslogtreecommitdiff
path: root/devel/clanlib/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/clanlib/Makefile')
-rw-r--r--devel/clanlib/Makefile55
1 files changed, 9 insertions, 46 deletions
diff --git a/devel/clanlib/Makefile b/devel/clanlib/Makefile
index 2b7b4a8f0edf..4c7853d8d568 100644
--- a/devel/clanlib/Makefile
+++ b/devel/clanlib/Makefile
@@ -2,13 +2,12 @@
# Date created: 10 May 2000
# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
#
-# $Carpetsmoker: ports/devel/clanlib/Makefile,v 1.2 2007/07/22 00:53:05 carpetsmoker Exp $
+# $Carpetsmoker: ports/devel/clanlib/Makefile,v 1.3 2008/03/18 13:48:24 carpetsmoker Exp $
# $FreeBSD$
#
PORTNAME= clanlib
-PORTVERSION= 0.8.0
-PORTREVISION= 1
+PORTVERSION= 0.8.1
PORTEPOCH= 1
CATEGORIES= devel
MASTER_SITES= http://www.clanlib.org/download/releases-0.8/ \
@@ -21,7 +20,9 @@ MAINTAINER= carpetsmoker@xs4all.nl
COMMENT= Cross-platform game SDK
LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
- png.5:${PORTSDIR}/graphics/png
+ png.5:${PORTSDIR}/graphics/png \
+ mikmod:${PORTSDIR}/audio/libmikmod \
+ vorbis:${PORTSDIR}/audio/libvorbis
WRKSRC= ${WRKDIR}/ClanLib-${PORTVERSION}
CPPFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
@@ -34,6 +35,8 @@ USE_GMAKE= yes
USE_XLIB= yes
USE_GNOME= gnomehack gnometarget pkgconfig
USE_LDCONFIG= yes
+USE_SDL= gfx
+USE_GL= yes
.include <bsd.port.pre.mk>
@@ -51,53 +54,13 @@ LDFLAGS+= -lstlport_gcc
CFLAGS+= -O0
.endif
-.if defined(WITHOUT_SDL)
-CONFIGURE_ARGS+=--disable-clanSDL
-PLIST_SUB+= SDL="@comment "
-.else
-USE_SDL= gfx
-CONFIGURE_ARGS+=--disable-sdltest
-PLIST_SUB+= SDL=""
-.endif
-
-.if defined(WITHOUT_OPENGL)
-CONFIGURE_ARGS+=--disable-clanGL
-PLIST_SUB+= OPENGL="@comment "
-.else
-USE_GL= yes
-PLIST_SUB+= OPENGL=""
-.endif
-
-.if defined(WITHOUT_MIKMOD)
-CONFIGURE_ARGS+=--disable-clanMikMod
-PLIST_SUB+= LIBMIKMOD="@comment "
-.else
-LIB_DEPENDS+= mikmod:${PORTSDIR}/audio/libmikmod
-PLIST_SUB+= LIBMIKMOD=""
-.endif
-
-.if defined(WITHOUT_VORBIS)
-CONFIGURE_ARGS+=--disable-clanVorbis
-PLIST_SUB+= LIBVORBIS="@comment "
-.else
-LIB_DEPENDS+= vorbis:${PORTSDIR}/audio/libvorbis
-PLIST_SUB+= LIBVORBIS=""
-.endif
-
-pre-everything::
- @${ECHO_MSG} "ClanLib has the following tunables options:"
- @${ECHO_MSG} ""
- @${ECHO_MSG} " WITHOUT_SDL=yes Turns off SDL support"
- @${ECHO_MSG} " WITHOUT_OPENGL=yes Turns off OpenGL support"
- @${ECHO_MSG} " WITHOUT_MIKMOD=yes Turns off libmikmod support"
- @${ECHO_MSG} " WITHOUT_VORBIS=yes Turns off libvorbis support"
- @${ECHO_MSG} ""
-
post-patch:
@${GREP} -lR "SDL/SDL" ${WRKSRC} | ${XARGS} ${REINPLACE_CMD} -e \
's|SDL/SDL|SDL|g'
@${REINPLACE_CMD} -e 's|(CLvoid)|()|' \
${WRKSRC}/Sources/API/GL/opengl_wrap.h
+ @${REINPLACE_CMD} -e 's|-lasound||' \
+ ${WRKSRC}/Sources/Sound/Makefile.in
@${REINPLACE_CMD} -e 's|@perl_exec@|${PERL}|g' \
${WRKSRC}/Documentation/Utilities/webbuilder.pl.in