aboutsummaryrefslogtreecommitdiff
path: root/devel/cmake-gui
diff options
context:
space:
mode:
Diffstat (limited to 'devel/cmake-gui')
-rw-r--r--devel/cmake-gui/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/devel/cmake-gui/Makefile b/devel/cmake-gui/Makefile
index 8c33edb06336..0a53b45f5d14 100644
--- a/devel/cmake-gui/Makefile
+++ b/devel/cmake-gui/Makefile
@@ -2,6 +2,7 @@
PORTNAME= cmake
PORTVERSION= 3.5.2
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= https://www.cmake.org/files/v${PORTVERSION:R}/
PKGNAMESUFFIX= -gui
@@ -14,10 +15,12 @@ LICENSE_FILE= ${WRKSRC}/Copyright.txt
BUILD_DEPENDS= sphinx-build:textproc/py-sphinx
LIB_DEPENDS= libcurl.so:ftp/curl \
- libexpat.so:textproc/expat2
+ libexpat.so:textproc/expat2 \
+ libjsoncpp.so:devel/jsoncpp
USE_QT5= core gui widgets buildtools_build qmake_build
-USES= cmake:run desktop-file-utils libarchive shared-mime-info
+USES= cmake:run desktop-file-utils execinfo libarchive \
+ shared-mime-info
CMAKE_ARGS= -DBUILD_QtDialog:bool=on \
-DBUILD_CursesDialog:BOOL=OFF \
-DSPHINX_MAN:BOOL=ON \