aboutsummaryrefslogtreecommitdiff
path: root/devel/cobf/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/cobf/Makefile')
-rw-r--r--devel/cobf/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/devel/cobf/Makefile b/devel/cobf/Makefile
new file mode 100644
index 000000000000..d382aaebefd6
--- /dev/null
+++ b/devel/cobf/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: cobf
+# Date created: 14 May 2006
+# Whom: Ed Schouten <ed@fxq.nl>
+#
+# $FreeBSD$
+#
+
+PORTNAME= cobf
+PORTVERSION= 1.06
+CATEGORIES= devel
+MASTER_SITES= http://home.arcor.de/bernhard.baier/${PORTNAME}/
+DISTNAME= ${PORTNAME}_${PORTVERSION}
+
+MAINTAINER= ed@fxq.nl
+COMMENT= C and C++ code obfuscator
+
+USE_ZIP= yes
+WRKSRC= ${WRKDIR}
+PORTDOCS= COPYING README cobf.pdf
+PLIST_FILES= bin/cobf
+
+do-build:
+ @${MAKE} -C ${WRKSRC}/src/cpp
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/cpp/cobf ${PREFIX}/bin/cobf
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/copyright.txt ${DOCSDIR}/COPYING
+ ${INSTALL_DATA} ${WRKSRC}/readme.txt ${DOCSDIR}/README
+ ${INSTALL_DATA} ${WRKSRC}/doc/cobf.pdf ${DOCSDIR}/cobf.pdf
+.endif
+
+.include <bsd.port.mk>