aboutsummaryrefslogtreecommitdiff
path: root/devel/cocktail/files/patch-puma-ffaba-c-Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/cocktail/files/patch-puma-ffaba-c-Makefile')
-rw-r--r--devel/cocktail/files/patch-puma-ffaba-c-Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/devel/cocktail/files/patch-puma-ffaba-c-Makefile b/devel/cocktail/files/patch-puma-ffaba-c-Makefile
new file mode 100644
index 000000000000..a4c4e89389e0
--- /dev/null
+++ b/devel/cocktail/files/patch-puma-ffaba-c-Makefile
@@ -0,0 +1,25 @@
+--- ../../work/cocktail-9309//./puma/ffaba-c/Makefile Tue Feb 15 14:26:16 1994
++++ ./puma/ffaba-c/Makefile Wed Mar 31 22:35:05 2004
+@@ -1,13 +1,9 @@
+-LIB = $(HOME)/lib
+-INCDIR = $(LIB)/include
+-CFLAGS = -I$(INCDIR)
+-CC = cc -O
+
+ all: main
+ time main
+
+ main: ProTest.o Compiler.o
+- cc -o main Compiler.o ProTest.o $(LIB)/libreuse.a
++ $(CC) -o main Compiler.o ProTest.o $(LIB)/libreuse.a
+
+ ProTest.o: ProTest.h
+ Compiler.o: ProTest.h
+@@ -24,5 +20,5 @@
+ clean:
+ rm -f core Compiler.* ProTest.* yy*.w main
+
+-.c.o:
+- $(CC) $(CFLAGS) -c $*.c;
++.include "../../Makefile.inc"
++