aboutsummaryrefslogtreecommitdiff
path: root/devel/commoncpp/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/commoncpp/Makefile')
-rw-r--r--devel/commoncpp/Makefile20
1 files changed, 11 insertions, 9 deletions
diff --git a/devel/commoncpp/Makefile b/devel/commoncpp/Makefile
index 9246596f8c8b..b9425950aca0 100644
--- a/devel/commoncpp/Makefile
+++ b/devel/commoncpp/Makefile
@@ -6,24 +6,26 @@
#
PORTNAME= commoncpp2
-PORTVERSION= 1.1.0
-PORTREVISION= 0
+PORTVERSION= 1.2.7
PORTEPOCH= 1
CATEGORIES= devel
-MASTER_SITES= ${MASTER_SITE_GNU} \
- ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= commonc++ cplusplus
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= gnutelephony
MAINTAINER= ports@FreeBSD.org
COMMENT= GNU project portable class framework for C++
-USE_GETOPT_LONG=yes
-USE_GNOME= gnometarget libxml2
-GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
+USE_GNOME= gnomehack gnometarget libxml2
+USE_GETOPT_LONG= yes
USE_GMAKE= yes
+USE_LIBTOOL_VER= 15
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}" \
+ ac_cv_path_DOXYGEN=no
INSTALLS_SHLIB= yes
INFO= commoncpp2
+CPPFLAGS= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
+LDFLAGS= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
+
.include <bsd.port.mk>