aboutsummaryrefslogtreecommitdiff
path: root/devel/commoncpp/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/commoncpp/Makefile')
-rw-r--r--devel/commoncpp/Makefile26
1 files changed, 17 insertions, 9 deletions
diff --git a/devel/commoncpp/Makefile b/devel/commoncpp/Makefile
index edfed2aadb1d..12eb3c50ace8 100644
--- a/devel/commoncpp/Makefile
+++ b/devel/commoncpp/Makefile
@@ -4,31 +4,39 @@
#
# $FreeBSD$
#
+# Copyright (c) 1999-2001 by Open Source Telecom Corporation.
+# Verbatim copying and distribution of this entire file is permitted
+# in any medium, provided this notice is preserved.
PORTNAME= CommonC++
-PORTVERSION= 1.2.5.1
+PORTVERSION= 1.4.1
CATEGORIES= devel
-MASTER_SITES= ftp://www.voxilla.org/pub/ape/ \
+MASTER_SITES= ftp://www.voxilla.org/pub/freebsd/tarball/ \
${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= cplusplus
MAINTAINER= dyfet@gnu.org
+LIB_DEPENDS= gnugetopt.1:${PORTSDIR}/devel/libgnugetopt \
+ xml2.5:${PORTSDIR}/textproc/libxml2
+
USE_GMAKE= yes
USE_LIBTOOL= yes
+USE_AUTOCONF= yes
INSTALLS_SHLIB= yes
-pre-patch:
- @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
- 's|-release \$$\(LT_RELEASE\)||g'
- @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
- s|l\$$ost_cv_thread_library|\$$ost_cv_thread_library|g ; \
- s|=c_r|=pthread|g' ${WRKSRC}/configure
+CONFIGURE_ENV= CPPFLAGS=-I${LOCALBASE}/include LDFLAGS=-L${LOCALBASE}/lib
+
+#post-extract:
+# cd ${WRKSRC} ; ./configure
+# @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
+# 's|-release \$$\(LT_RELEASE\)||g'
post-install:
+ (cd ${WRKSRC} ; make man)
.if !defined(NOPORTDOCS)
${MKDIR} ${PREFIX}/share/doc/commoncpp
- ${INSTALL_MAN} ${WRKSRC}/doc/*.html ${PREFIX}/share/doc/commoncpp
+ ${INSTALL_MAN} ${WRKSRC}/doc/html/* ${PREFIX}/share/doc/commoncpp
.endif
.include <bsd.port.mk>